Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65730 - [xorg-xkbcomp] Could not resolve keysym XF86FullScreen

Attached to Project: Arch Linux
Opened by Hugo Hromic (hhromic) - Saturday, 07 March 2020, 12:32 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 17 March 2020, 09:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I'm receiving internal errors caused by xkbcomp not able to find newer symbols:

For example, using xvfb:

# xvfb-run -e /dev/stderr true
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Internal error: Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server


Additional info:

* package version(s)

xorg-server-xvfb 1.20.7-1
xorg-xkbcomp 1.4.3-1
xkeyboard-config 2.29-1
xorgproto 2019.2-2


* config and/or log files etc.

* link to upstream bug report, if any

Similar to previous bug: https://bugs.archlinux.org/task/62449
Where it is suggested to recompile xkbcomp after updating xorgproto and xkeyboard-config.

Steps to reproduce:

Start any command using xvfb with stderr enabled. For example:

xvfb-run -e /dev/stderr true
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 17 March 2020, 09:26 GMT
Reason for closing:  Upstream
Comment by Andreas Radke (AndyRTR) - Saturday, 07 March 2020, 20:52 GMT
Recompiling xorg-xkbcomp and even xorg-server(-xvfb) doesn't fix that error here.
Comment by loqs (loqs) - Saturday, 07 March 2020, 23:26 GMT Comment by Hugo Hromic (hhromic) - Saturday, 07 March 2020, 23:31 GMT
Yes, I was going to comment on the same!

The `xkeyboard-config` package introduced the new keysym `XF86FullScreen` in the recent `2.29` version via this merge request: https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/-/commit/d121a0aa5cc1de22778e2ac39929fecbe5b50623

However this symbol has not been yet added to the `libxkbcommon` package, more precisely to the file `/usr/include/xkbcommon/xkbcommon-keysyms.h`. This because the new symbol has not been added to the `xorgproto` package.

The error is temporarily fixed by reverting `xkeyboard-config` to `2.28` because this version does not have the new keysym. The proper fix should be to add the missing symbol to `xorgproto` and `libxkbcommon` and recompile everything that depends on them.
Comment by Andreas Radke (AndyRTR) - Sunday, 08 March 2020, 12:11 GMT
Is there something broken and not starting or is this just an error reported and as stated not fatal?
Comment by Hugo Hromic (hhromic) - Sunday, 08 March 2020, 18:00 GMT
No, programs are not broken and errors are not fatal indeed. They are just annoying to see.

At the time of opening I thought it was a packaging bug but after the discovery of yesterday perhaps this task can be closed as it is actually a bug in upstream.

Loading...