Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65700 - [atom] Unable to search for packages/themes

Attached to Project: Community Packages
Opened by Caleb Maclennan (caleb) - Wednesday, 04 March 2020, 15:09 GMT
Last edited by Nicola Squartini (tensor5) - Wednesday, 10 June 2020, 05:51 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Nicola Squartini (tensor5)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

All of my Arch Linux installs of Atom have stopped working since 1.44.0. I would blame the upstream release, but it seems other platforms and distros are working okay, so I suspect this might be Arch packaging related.

Everything works normally except the search for new packages or themes. Those just say "Searching packages for '<term>' ..." forever. Installing packages works from the featured list for example, as does updating ... so it's not a complete network block. Just that function is dead.

I don't have trouble accessing atom.io directly in a browser.
This task depends upon

Closed by  Nicola Squartini (tensor5)
Wednesday, 10 June 2020, 05:51 GMT
Reason for closing:  Fixed
Comment by Caleb Maclennan (caleb) - Wednesday, 11 March 2020, 16:26 GMT Comment by Nicola Squartini (tensor5) - Wednesday, 10 June 2020, 01:09 GMT
Does this problem still show up? I'm able to search packages and themes normally.
Comment by Caleb Maclennan (caleb) - Wednesday, 10 June 2020, 05:38 GMT
@tensor5 No, I just checked one system I know was affected (now on 1.47.0) and at some point this seems to have been resolved because it works now.

Loading...