Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65697 - [hplip] print jobs not starting after update to 1:3.20.2-1

Attached to Project: Arch Linux
Opened by Gerhard Bogner (slashME) - Tuesday, 03 March 2020, 18:15 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 11 March 2020, 20:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

With version 1:3.20.2-1 submitting documents to print seems to work fine, but the network printer (a HP OfficeJet 6500a) never seems to start the job. According to CUPS the current job is always "processing page 1". Following errors can be found in its log:

... hp[530]: io/hpmud/jd.c 93: unable to read device-id
... hp[530]: prnt/backend/hp.c 824: ERROR: open device failed stat=12: hp:/net/Officejet_6500_E710a-f?ip=192.168.0.117

Downgrading to 1:3.19.12-1 and restarting org.cups.cupsd causes queued jobs to start printing.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 11 March 2020, 20:01 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Thursday, 05 March 2020, 19:43 GMT
Please report this upstream.
Comment by Andreas Radke (AndyRTR) - Thursday, 05 March 2020, 19:46 GMT Comment by Gerhard Bogner (slashME) - Monday, 09 March 2020, 17:11 GMT
already reported (by someone else) at https://bugs.launchpad.net/hplip/+bug/1866291 on HPLIP's launchpad
Comment by Slawomir Grodzki (infoslaw) - Monday, 09 March 2020, 21:46 GMT
I have exactly the same bug with network printer HP ENVY 4500.
Comment by Gerhard Bogner (slashME) - Tuesday, 10 March 2020, 15:46 GMT
There's a patch at https://bugs.launchpad.net/hplip/+bug/1866291/comments/4 that is supposed to fix the issue and a new release (3.20.3) which includes it.
Comment by Andreas Radke (AndyRTR) - Wednesday, 11 March 2020, 16:28 GMT
Does the new release 3.20.3 work for you?
Comment by Laurent Carlier (lordheavy) - Wednesday, 11 March 2020, 17:00 GMT
just tested, and it's fixed with 3.20.3 release (HP 8600 plus)
Comment by Slawomir Grodzki (infoslaw) - Wednesday, 11 March 2020, 18:10 GMT
For me as well hplip 3.20.3 fixed network printing (HP ENVY 4500).

Loading...