Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65668 - [remmina] Please enable indicator icon support

Attached to Project: Community Packages
Opened by Alexandros (akarypid) - Sunday, 01 March 2020, 11:42 GMT
Last edited by Sergej Pupykin (sergej) - Sunday, 05 April 2020, 00:17 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The package is compiled without "appindicator". As a result, you are unable to use the "tray icon" or start it minimized to the notification are.

Additional info:

* package version(s):

I came across this in Manjaro 19 which has version:
remmina 1:1.3.10-1

It is still present (checked SVN) in Arch in latest version:
remmina 1:1.4.1-1

* config and/or log files etc. :

When using the app from the GUI you can tell it is not working because of the absence of the icon in the notification area.

* link to upstream bug report, if any

Came across this myself. Searching in Manjaro forums I quickly found:

https://forum.manjaro.org/t/remmina-applet-indicator-not-showing/95752

I could not find a bug report for the package in Arch so I am creating this one.

Steps to reproduce:
--------------------------------

The best way to replicate and have evidence of it happening is to run:

[user@workstation ~]$ remmina -i
...
StatusNotifier/Appindicator support: your desktop does support it, but you did not compile remmina with cmake’s -DWITH_APPINDICATOR=on


Steps to fix:
--------------------------------
https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/remmina

Line 38 of the PKGBUILD file above should be changed to ON.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Sunday, 05 April 2020, 00:17 GMT
Reason for closing:  Fixed

Loading...