Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65635 - [linux] 5.5.6 & sof-audio-pci: BUG: unable to handle page fault for address: 000005dc00000000

Attached to Project: Arch Linux
Opened by Victor Trac (victortrac) - Thursday, 27 February 2020, 04:02 GMT
Last edited by freswa (frederik) - Sunday, 01 March 2020, 00:17 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

Description:
Upgrading to linux-5.5.6 with sof-firmware installed results in this error when booting:
Feb 26 20:51:31 carbon kernel: sof-audio-pci 0000:00:1f.3: unexpected ipc interrupt raised!
Feb 26 20:51:31 carbon kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Feb 26 20:51:32 carbon kernel: sof-audio-pci 0000:00:1f.3: Firmware info: version 1:4:2-66a5a
Feb 26 20:51:32 carbon kernel: sof-audio-pci 0000:00:1f.3: Firmware: ABI 3:11:0 Kernel ABI 3:11:0
Feb 26 20:51:32 carbon kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete
Feb 26 20:51:32 carbon kernel: BUG: unable to handle page fault for address: 000005dc00000000
Feb 26 20:51:32 carbon kernel: #PF: supervisor read access in kernel mode
Feb 26 20:51:32 carbon kernel: #PF: error_code(0x0000) - not-present page
Feb 26 20:51:32 carbon kernel: PGD 0 P4D 0
Feb 26 20:51:32 carbon kernel: Oops: 0000 [#1] PREEMPT SMP NOPTI
Feb 26 20:51:32 carbon kernel: CPU: 6 PID: 57 Comm: kworker/6:0 Tainted: G U 5.5.6-arch1-1 #1
Feb 26 20:51:32 carbon kernel: Hardware name: LENOVO 20R10015US/20R10015US, BIOS N2QET19W (1.13 ) 01/15/2020
Feb 26 20:51:32 carbon kernel: Workqueue: events sof_probe_work [snd_sof]
Feb 26 20:51:32 carbon kernel: RIP: 0010:strlen+0x0/0x20
Feb 26 20:51:32 carbon kernel: Code: 48 89 f9 74 09 48 83 c1 01 80 39 00 75 f7 31 d2 44 0f b6 04 16 44 88 04 11 48 83 c2 01 45 84 c0 75 ee c3 0f 1f 80 00 00 00 00 <80> 3f 00 74 10 48 89 f8 48 83 c0 01 80 38 00 75 f7 48 29 f8 c3 31
Feb 26 20:51:32 carbon kernel: RSP: 0018:ffff9c59402b3d30 EFLAGS: 00010206
Feb 26 20:51:32 carbon kernel: RAX: ffff9084a3b0fe58 RBX: ffff9084aa267e18 RCX: 0000000000000000
Feb 26 20:51:32 carbon kernel: RDX: 0000000000000cc0 RSI: 000005dc00000000 RDI: 000005dc00000000
Feb 26 20:51:32 carbon kernel: RBP: 000005dc00000000 R08: ffff9084ae807100 R09: ffff9084ae807100
Feb 26 20:51:32 carbon kernel: R10: 0000000000000010 R11: f000000000000000 R12: ffff9084a3b0fe58
Feb 26 20:51:32 carbon kernel: R13: ffff9084ad72c0b0 R14: 0000000000000cc0 R15: 000000000000000f
Feb 26 20:51:32 carbon kernel: FS: 0000000000000000(0000) GS:ffff9084b0580000(0000) knlGS:0000000000000000
Feb 26 20:51:32 carbon kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 26 20:51:32 carbon kernel: CR2: 000005dc00000000 CR3: 000000024da0a005 CR4: 00000000003606e0
Feb 26 20:51:32 carbon kernel: Call Trace:
Feb 26 20:51:32 carbon kernel: devm_kstrdup+0x22/0x60
Feb 26 20:51:32 carbon kernel: snd_soc_register_dai+0x6c/0x170 [snd_soc_core]
Feb 26 20:51:32 carbon kernel: snd_soc_add_component+0xf9/0x2c0 [snd_soc_core]
Feb 26 20:51:32 carbon kernel: devm_snd_soc_register_component+0x4e/0x90 [snd_soc_core]
Feb 26 20:51:32 carbon kernel: sof_probe_work+0x110/0x290 [snd_sof]
Feb 26 20:51:32 carbon kernel: process_one_work+0x1e1/0x3d0
Feb 26 20:51:32 carbon kernel: worker_thread+0x4a/0x3d0
Feb 26 20:51:32 carbon kernel: kthread+0xfb/0x130
Feb 26 20:51:32 carbon kernel: ? process_one_work+0x3d0/0x3d0
Feb 26 20:51:32 carbon kernel: ? kthread_park+0x90/0x90
Feb 26 20:51:32 carbon kernel: ret_from_fork+0x1f/0x40
Feb 26 20:51:32 carbon kernel: Modules linked in: pcc_cpufreq(-) snd_hda_codec_hdmi snd_soc_hdac_hdmi snd_hda_codec_realtek joydev iTCO_wdt mousedev snd_soc_dmic iTCO_vendor_support snd_hda_codec_generic hid_multitouch mei_hdcp snd_sof_pci snd_sof_intel_>
Feb 26 20:51:32 carbon kernel: rfkill intel_soc_dts_iosf typec rng_core wmi snd i2c_hid soundcore int3403_thermal battery ac int340x_thermal_zone evdev int3400_thermal acpi_thermal_rel mac_hid acpi_tad pkcs8_key_parser crypto_user ip_tables x_tables ext>
Feb 26 20:51:32 carbon kernel: CR2: 000005dc00000000
Feb 26 20:51:32 carbon kernel: ---[ end trace e72a52694d740eec ]---
Feb 26 20:51:32 carbon kernel: RIP: 0010:strlen+0x0/0x20
Feb 26 20:51:32 carbon kernel: Code: 48 89 f9 74 09 48 83 c1 01 80 39 00 75 f7 31 d2 44 0f b6 04 16 44 88 04 11 48 83 c2 01 45 84 c0 75 ee c3 0f 1f 80 00 00 00 00 <80> 3f 00 74 10 48 89 f8 48 83 c0 01 80 38 00 75 f7 48 29 f8 c3 31
Feb 26 20:51:32 carbon kernel: RSP: 0018:ffff9c59402b3d30 EFLAGS: 00010206
Feb 26 20:51:32 carbon kernel: RAX: ffff9084a3b0fe58 RBX: ffff9084aa267e18 RCX: 0000000000000000
Feb 26 20:51:32 carbon kernel: RDX: 0000000000000cc0 RSI: 000005dc00000000 RDI: 000005dc00000000
Feb 26 20:51:32 carbon kernel: RBP: 000005dc00000000 R08: ffff9084ae807100 R09: ffff9084ae807100
Feb 26 20:51:32 carbon kernel: R10: 0000000000000010 R11: f000000000000000 R12: ffff9084a3b0fe58
Feb 26 20:51:32 carbon kernel: R13: ffff9084ad72c0b0 R14: 0000000000000cc0 R15: 000000000000000f
Feb 26 20:51:32 carbon kernel: FS: 0000000000000000(0000) GS:ffff9084b0580000(0000) knlGS:0000000000000000
Feb 26 20:51:32 carbon kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 26 20:51:32 carbon kernel: CR2: 000005dc00000000 CR3: 000000024da0a005 CR4: 00000000003606e0

tty2 login also just freezes after typing in the username. Reverting to linux-5.5.5 or linux-lts resolves the issue.


Additional info:
* package version(s):
linux-5.5.6
sof-firmware 1.4.2-1
* hardware: Lenovo X1 Carbon (7th gen)

ArchLinux forum post: https://bbs.archlinux.org/viewtopic.php?pid=1889475

Steps to reproduce:
Upgrade to linux-5.5.6 with sof-firmware installed.
This task depends upon

Closed by  freswa (frederik)
Sunday, 01 March 2020, 00:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  5.5.7.arch1-1
Comment by Stefan (willist) - Thursday, 27 February 2020, 12:01 GMT
Same here with Lenovo X1 Carbon 7th Gen 20QDCTO1WW. I added a boot log. I installed sof firmware because of https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_X1_Carbon_(Gen_7)#Audio.

I hope this is helpful.
   boot.log (146.9 KiB)
Comment by Alan (Caust1c) - Thursday, 27 February 2020, 13:00 GMT
I'm seeing the same thing! Also on x1c7, 20QD000SUS.

Installed same firmware fix for the mic.
   boot.log (6.2 KiB)
Comment by loqs (loqs) - Thursday, 27 February 2020, 20:54 GMT
https://lore.kernel.org/stable/e15641c3-2cf8-db66-3eeb-019af4b482db%40redhat.com/

24c259557c45e817941d3843f82331a477c86a7e is the causal commit which depends upon

e68d6696575e1af3f92125e842f2853708f34589 that was not backported.

Queued for 5.5.7 https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/commit/?id=a78cc732c4b80a5f90190c2c65d4ce608526e90d
Comment by Marc Vertes (mvertes) - Friday, 28 February 2020, 11:34 GMT
I'm seeing the same on Acer Swift SF515-51T, which was ok with linux-5.5.5



Feb 28 12:12:28 swift kernel: sof-audio-pci 0000:00:1f.3: unexpected ipc interrupt raised!
Feb 28 12:12:28 swift kernel: sof-audio-pci 0000:00:1f.3: error: no reply expected, received 0x0
Feb 28 12:12:28 swift systemd[1]: Reached target Bluetooth.
Feb 28 12:12:28 swift dbus-daemon[429]: [system] Activating via systemd: service name='org.freedesktop.ColorManager' unit='colord.service' requested by ':1.4' (uid=0 pid=520 comm="/usr/bin/cupsd -l ")
Feb 28 12:12:28 swift systemd[1]: Starting Manage, Install and Generate Color Profiles...
Feb 28 12:12:28 swift kernel: iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
Feb 28 12:12:28 swift kernel: sof-audio-pci 0000:00:1f.3: Firmware info: version 1:4:2-66a5a
Feb 28 12:12:28 swift kernel: sof-audio-pci 0000:00:1f.3: Firmware: ABI 3:11:0 Kernel ABI 3:11:0
Feb 28 12:12:28 swift kernel: sof-audio-pci 0000:00:1f.3: firmware boot complete
Feb 28 12:12:28 swift kernel: BUG: unable to handle page fault for address: 000005dc00000000
Feb 28 12:12:28 swift kernel: #PF: supervisor read access in kernel mode
Feb 28 12:12:28 swift kernel: #PF: error_code(0x0000) - not-present page
Feb 28 12:12:28 swift kernel: PGD 0 P4D 0
Feb 28 12:12:28 swift kernel: Oops: 0000 [#1] PREEMPT SMP NOPTI
Feb 28 12:12:28 swift kernel: CPU: 0 PID: 312 Comm: kworker/0:2 Not tainted 5.5.6-arch1-1 #1
Feb 28 12:12:28 swift kernel: Hardware name: Acer Swift SF515-51T/Guinness_WL, BIOS V1.04 05/24/2019
Feb 28 12:12:28 swift kernel: Workqueue: events sof_probe_work [snd_sof]
Feb 28 12:12:28 swift kernel: RIP: 0010:strlen+0x0/0x20
Feb 28 12:12:28 swift kernel: Code: 48 89 f9 74 09 48 83 c1 01 80 39 00 75 f7 31 d2 44 0f b6 04 16 44 88 04 11 48 83 c2 01 45 84 c0 75 ee c3 0f 1f 80 00 00 00 00 <80> 3f 00 74 10 48 89 f8 48 83 c0 01 80 38 00 75 f7 48 29 f8 c3 31
Feb 28 12:12:28 swift kernel: RSP: 0018:ffff920a00753d30 EFLAGS: 00010206
Feb 28 12:12:28 swift kernel: RAX: ffff8a6098b7fd98 RBX: ffff8a6097060218 RCX: 0000000000000000
Feb 28 12:12:28 swift kernel: RDX: 0000000000000cc0 RSI: 000005dc00000000 RDI: 000005dc00000000
Feb 28 12:12:28 swift kernel: RBP: 000005dc00000000 R08: ffff8a609c007100 R09: ffff8a609c007100
Feb 28 12:12:28 swift kernel: R10: 00000000000331c0 R11: 0000000000000005 R12: ffff8a6098b7fd98
Feb 28 12:12:28 swift kernel: R13: ffff8a609ae1e0b0 R14: 0000000000000cc0 R15: 000000000000000f
Feb 28 12:12:28 swift kernel: FS: 0000000000000000(0000) GS:ffff8a609dc00000(0000) knlGS:0000000000000000
Feb 28 12:12:28 swift kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 28 12:12:28 swift kernel: CR2: 000005dc00000000 CR3: 00000001ea60a004 CR4: 00000000003606f0
Feb 28 12:12:28 swift kernel: Call Trace:
Feb 28 12:12:28 swift kernel: devm_kstrdup+0x22/0x60
Feb 28 12:12:28 swift kernel: snd_soc_register_dai+0x6c/0x170 [snd_soc_core]
Feb 28 12:12:28 swift kernel: snd_soc_add_component+0xf9/0x2c0 [snd_soc_core]
Feb 28 12:12:28 swift kernel: devm_snd_soc_register_component+0x4e/0x90 [snd_soc_core]
Feb 28 12:12:28 swift kernel: sof_probe_work+0x110/0x290 [snd_sof]
Feb 28 12:12:28 swift kernel: process_one_work+0x1e1/0x3d0
Feb 28 12:12:28 swift kernel: worker_thread+0x4a/0x3d0
Feb 28 12:12:28 swift kernel: kthread+0xfb/0x130
Feb 28 12:12:28 swift kernel: ? process_one_work+0x3d0/0x3d0
Feb 28 12:12:28 swift kernel: ? kthread_park+0x90/0x90
Feb 28 12:12:28 swift kernel: ret_from_fork+0x35/0x40
Feb 28 12:12:28 swift kernel: Modules linked in: acpi_cpufreq(-) btusb snd_hda_codec_hdmi snd_soc_hdac_hdmi btrtl btbcm snd_hda_codec_realtek btintel joydev bluetooth snd_hda_codec_generic snd_soc_dmic snd_sof_pci snd_sof_intel_byt snd_sof_intel_ipc uvcvideo snd_sof_xtensa_dsp snd_sof_intel_hda_common mousedev video>
Feb 28 12:12:28 swift kernel: input_leds pcspkr snd i2c_i801 soundcore cfg80211 mei_me mei processor_thermal_device intel_rapl_common intel_lpss_pci intel_lpss rfkill intel_soc_dts_iosf idma64 intel_pch_thermal tpm_crb ucsi_acpi typec_ucsi typec i2c_hid wmi hid tpm_tis tpm_tis_core int3403_thermal int340x_thermal_z>
Feb 28 12:12:28 swift kernel: CR2: 000005dc00000000
Feb 28 12:12:28 swift kernel: ---[ end trace 1450f622c241d055 ]---
Feb 28 12:12:28 swift kernel: RIP: 0010:strlen+0x0/0x20
Feb 28 12:12:28 swift kernel: Code: 48 89 f9 74 09 48 83 c1 01 80 39 00 75 f7 31 d2 44 0f b6 04 16 44 88 04 11 48 83 c2 01 45 84 c0 75 ee c3 0f 1f 80 00 00 00 00 <80> 3f 00 74 10 48 89 f8 48 83 c0 01 80 38 00 75 f7 48 29 f8 c3 31
Feb 28 12:12:28 swift kernel: RSP: 0018:ffff920a00753d30 EFLAGS: 00010206
Feb 28 12:12:28 swift kernel: RAX: ffff8a6098b7fd98 RBX: ffff8a6097060218 RCX: 0000000000000000
Feb 28 12:12:28 swift kernel: RDX: 0000000000000cc0 RSI: 000005dc00000000 RDI: 000005dc00000000
Feb 28 12:12:28 swift kernel: RBP: 000005dc00000000 R08: ffff8a609c007100 R09: ffff8a609c007100
Feb 28 12:12:28 swift kernel: R10: 00000000000331c0 R11: 0000000000000005 R12: ffff8a6098b7fd98
Feb 28 12:12:28 swift kernel: R13: ffff8a609ae1e0b0 R14: 0000000000000cc0 R15: 000000000000000f
Feb 28 12:12:28 swift kernel: FS: 0000000000000000(0000) GS:ffff8a609dc00000(0000) knlGS:0000000000000000
Feb 28 12:12:28 swift kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 28 12:12:28 swift kernel: CR2: 000005dc00000000 CR3: 00000001ea60a004 CR4: 00000000003606f0
Comment by Marc Vertes (mvertes) - Friday, 28 February 2020, 15:03 GMT
The workaround for me is to fallback on the legacy DSP driver, instead of the SOF driver which is now the default since linux-5.4.x.

This is done with the following content in /etc/modprobe.d/alsa.conf:
# Select DSP driver instead of SOF
options snd-intel-dspcfg dsp_driver=1
# Enable headset mic detection
options snd-hda-intel model=dell-headset-multi

For me, the SOF driver is not yet stable / usable enough for daily use. The DSP driver should remain the default one.

Pro: more stable. Ability to use the headset mic. Same behavior for sound as previous kernels (before linux-5.4).

Con: front mic disabled.
Comment by loqs (loqs) - Saturday, 29 February 2020, 21:07 GMT
Can you confirm the issue is resolved by linux 5.5.7.arch1-1 currently in testing?
Comment by Marc Vertes (mvertes) - Saturday, 29 February 2020, 22:22 GMT
I confirm that linux-5.5.7-arch1_1 from testing fixes the issue, tested on Acer Swift SF515-51T.

Loading...