Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#65611 - [python-astroid] astroid depends on wrong version of python-wrapt

Attached to Project: Arch Linux
Opened by Karthik (wpd) - Monday, 24 February 2020, 10:10 GMT
Last edited by Felix Yan (felixonmars) - Monday, 24 February 2020, 21:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



Astroid 2.3.3 depends on wrapt 1.11.* ( But python-wrapt package is already at 1.12. This dependency needs to be fixed as the upstream lists an older dependency than what arch provides.

Additional info:
* python-astroid 2.3.3-1

Steps to reproduce:

* Install python-astroid and python-wrapt
** Astroid is now in a broken state
This task depends upon

Closed by  Felix Yan (felixonmars)
Monday, 24 February 2020, 21:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.3.3-2
Comment by Eli Schwartz (eschwartz) - Monday, 24 February 2020, 12:08 GMT
As I had mentioned to Felix on IRC...


Caused by this strange commit:

They suddenly decided to do exact version pinning for everything, this is plainly wrong...