Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65548 - [redmine] Ruby 2.7 Not Supported

Attached to Project: Community Packages
Opened by Matthew Sexton (wsdmatty) - Tuesday, 18 February 2020, 22:29 GMT
Last edited by Sergej Pupykin (sergej) - Wednesday, 19 February 2020, 23:07 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Redmine 4.0.5-1
Ruby 2.7.0-1
Rubygems 3.1.2-4
Ruby-bundler 2.1.4-1

Running a Redmine instance using the above official packages results in Internal Server Error (500) when trying to view the 'repositories' page of the webapp. The log file shows the issue as:

FrozenError (can't modify frozen String: ""):

This bug was reported to upstream: https://www.redmine.org/issues/33021

Related to this change in Ruby:
https://bugs.ruby-lang.org/issues/16150

Specifically, the issue is this line, which may return a frozen string:
https://github.com/redmine/redmine/blob/caa88a2ed308224edc66f411b1466a7e622994c3/app/controllers/repositories_controller.rb#L320

The issue is that this version of Redmine in the official repo does not yet support the latest version of Ruby.

Workaround:

Manually downgrading the following:
ruby (2.7.0-1 => 2.6.5-1)
rubygems (3.1.2-4 => 3.0.6-1)
ruby-bundler (2.1.4-1 => 2.0.2-1)

Then re-installing gems using "bundle install --without development test" and restarting the httpd service fixes the issue with no other noticeable side effects.

Obviously, downgrading packages is Not Supported Behavior. But hey, it made the app work.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Wednesday, 19 February 2020, 23:07 GMT
Reason for closing:  Fixed

Loading...