Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65536 - [keybase-gui] TopIcon is not visible at gnome-shell

Attached to Project: Community Packages
Opened by Reik Keutterling (Spielkind) - Tuesday, 18 February 2020, 10:27 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 18 February 2020, 11:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since the latest updates the Keybase TopIcon is not visible at gnome-shell.
Without this icon it's pretty hard to bring Keybase back from the "hidden" state.

Additional info:
* package version(s)
kbfs, keybase, keybase-gui -> 5.2.0-1
System/Gnome packages (versions of today): 1:3.34.4-1

Tried TopIcon Extensions:
https://extensions.gnome.org/extension/1674/topiconsfix/
https://extensions.gnome.org/extension/1031/topicons/
https://extensions.gnome.org/extension/1031/topicons/

* config and/or log files etc.
Other TopIcons still work:
- Slack
- Rambox
- Skype
- Steam

* link to upstream bug report, if any

Steps to reproduce:
Use gnome-shell, use any TopIcon Extension start Keybase-GUI
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 18 February 2020, 11:52 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#65483 
Comment by Reik Keutterling (Spielkind) - Tuesday, 18 February 2020, 10:44 GMT
Just tried to switch to "keybase-bin" package from AUR (keybase-bin-5.2.0_20200130211428+cf82db8320-1) where the Icon still works.
Comment by Jonas Witschel (diabonas) - Tuesday, 18 February 2020, 11:07 GMT
Duplicate of  FS#65483 : Electron 8 removed the support for legacy XEmbed tray icons, you need to use a tray extension that supports the StatusNotifier/AppIndicator protocol.

Loading...