Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65502 - [noto-fonts-emoji] Firefox shows emojis for numbers after upgrading to 20191016-2 or -3

Attached to Project: Arch Linux
Opened by John Ledbetter (ledbettj) - Friday, 14 February 2020, 16:47 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 15 February 2020, 08:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After upgrading from noto-fonts-emoji-20191016-1-any to -2 or -3, Firefox is using emojis for numbers only in it's UI, and has strange spacing between words. See the attached pictures.

Downgrading back to -1 resolves the issue.

Additional info:
* noto-fonts-emoji-20191016-2 and noto-fonts-emoji-20191016-3


Please let me know if there are specific configuration files I can include, I don't _think_ I've edited any font configuration files.
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 15 February 2020, 08:18 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Friday, 14 February 2020, 17:00 GMT
please post the output of 'fc-match sans'
Comment by John Ledbetter (ledbettj) - Friday, 14 February 2020, 17:24 GMT

$ fc-match sans

NimbusSans-Regular.otf: "Nimbus Sans" "Regular"


Comment by John Ledbetter (ledbettj) - Friday, 14 February 2020, 18:16 GMT
This looks like it's only happening in my existing Firefox profile, and not a fresh profile (with firefox -P). Perhaps this isn't an issue with this package after all.

I'll keep digging.
Comment by Seiji Kumagai (skumagai) - Friday, 14 February 2020, 19:03 GMT
I've encountered the same issue.

$ fc-match sans
DejaVuSans.ttf: "DejaVu Sans" "Book"

In my case, creating and using a new profile with --ProfileManager don't resolve the issue.
The attached image (firefox.png) is captured with the new profile.

I'd like to add that i3bar is also affected.

Downgrading to -1 resolved the issues for me too.
Comment by Antonio Rojas (arojas) - Friday, 14 February 2020, 19:09 GMT
@skumagai and 'fc-match serif'?
Comment by Seiji Kumagai (skumagai) - Friday, 14 February 2020, 23:48 GMT
$ fc-match serif
DejaVuSerif.ttf: "DejaVu Serif" "Book"
Comment by Antonio Rojas (arojas) - Saturday, 15 February 2020, 00:06 GMT
Also your ~/.config/gtk-3.0/settings.ini please
Comment by Seiji Kumagai (skumagai) - Saturday, 15 February 2020, 04:34 GMT
$ cat .config/gtk-3.0/settings.ini
[Settings]
gtk-font-name = Noto Mono 9
Comment by Antonio Rojas (arojas) - Saturday, 15 February 2020, 08:18 GMT
So there's your problem. There is no Noto Mono, it was replaced with Noto Sans Mono long ago. Change your GTK font to something that does actually exist.

Loading...