Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65498 - [mesa] Xorg crashes with 19.3.4

Attached to Project: Arch Linux
Opened by Trit' (trit) - Friday, 14 February 2020, 13:23 GMT
Last edited by Christian Hesse (eworm) - Saturday, 15 February 2020, 19:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 26
Private No

Details

Description:After having updated mesa to 19.3.4, LightDM won't start after rebooting the PC. I had to downgrade to 19.3.3 to make it start again.
Error codes: "systemctl status lightdm" → "code=exited, status=1/FAILURE)"
"lightdm.service: Start request repeated too quickly.
lightdm.service: Failed with result 'exit-code'.


Additional info:
* MESA 19.3.4
* Graphic card: Nvidia GeForce 210, with nouveau drivers (unsupported card for proprietary drivers)

Steps to reproduce: just update mesa package to version 19.3.4 and reboot.
This task depends upon

Closed by  Christian Hesse (eworm)
Saturday, 15 February 2020, 19:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa 19.3.4-2
Comment by Alexander Schnaidt (Namarrgon) - Friday, 14 February 2020, 13:26 GMT Comment by Dmitry Lyashuk (TerminalHash) - Friday, 14 February 2020, 13:32 GMT
All Display Managers crashing, not only LightDM.
Comment by Ville Aakko (Wild_Penguin) - Friday, 14 February 2020, 13:58 GMT
Confirmed.

There is an Illegal Instruction -error in Xorg.log. (log attached - attachment previously failed because of permission errors on my end :-F).
Comment by Jens G (Thah) - Friday, 14 February 2020, 14:09 GMT
Same problem with startx/fvwm. Xorg Error message reads "Illegal instruction at address $ADR" with
$ADR being within /bin/lib/dri/radeonsi_dri.so (owned by mesa package). Crash seems to happen before
fvwm gets run.

Downgrade to v19.3.3 solves problem.

Additionally, mpv started from X session started *prior* to mesa upgrade crashes as well.
Comment by Mike Dillamore (armadillo) - Friday, 14 February 2020, 15:37 GMT
Occurring here with GDM and Nouveau drivers
Comment by st.binder (nium) - Friday, 14 February 2020, 16:37 GMT
same here with amdgpu driver
Comment by gentoo_eshoes (gentoo_eshoes) - Friday, 14 February 2020, 17:18 GMT
ok ignore this comment, I made mistake:) it's still due to AVX but not because of the existence of those files

<s>
Seems like, if you have these it should illegal instruction on you:

$ ls -la /usr/lib/libswrAVX*
lrwxrwxrwx 1 root root 15 Feb 14 17:55 /usr/lib/libswrAVX2.so -> libswrAVX2.so.0
lrwxrwxrwx 1 root root 19 Feb 14 17:55 /usr/lib/libswrAVX2.so.0 -> libswrAVX2.so.0.0.0
-rwxr-xr-x 1 root root 147008360 Feb 14 17:55 /usr/lib/libswrAVX2.so.0.0.0
lrwxrwxrwx 1 root root 14 Feb 14 17:55 /usr/lib/libswrAVX.so -> libswrAVX.so.0
lrwxrwxrwx 1 root root 18 Feb 14 17:55 /usr/lib/libswrAVX.so.0 -> libswrAVX.so.0.0.0
-rwxr-xr-x 1 root root 170765368 Feb 14 17:55 /usr/lib/libswrAVX.so.0.0.0

</s>

EDIT: of course only if you don't have avx/avx2 ( $ grep avx /proc/cpuinfo )
EDIT2: with the exception of current mesa git master 20.1.0_devel.120156.946eacbafb4-1 which has those AVX files but doesn't crash
EDIT3: I guess I was wrong, you may have those files and still work for you, because mesa-19.3.3-1-x86_64.pkg.tar.zst also has them and it works. Now I don't remember what was the context when I didn't see those files and it worked, but it must've been some git version I've compiled using the non-git mesa. PKGBUILD...
Oh craap I remembered, it was a git version of 19.3.4 which didn't have the "swr" in -D gallium-drivers=
Comment by Philip Müller (philm) - Friday, 14 February 2020, 18:21 GMT
Maybe we can update this issue upstream: https://gitlab.freedesktop.org/mesa/mesa/issues/2520
Comment by gentoo_eshoes (gentoo_eshoes) - Friday, 14 February 2020, 20:36 GMT
fyi, the upstream commit 689817c9dfde9a0852f2b2489cb0fa93ffbcb215 cherry-picked on 19.3.4 fixes this.

https://gitlab.freedesktop.org/mesa/mesa/issues/2520#note_411359
Comment by Christian Hesse (eworm) - Friday, 14 February 2020, 22:29 GMT
Should be fixed in mesa 19.3.4-2.
Anybody wants to verify?
Comment by Viktor Jägersküpper (viktorjk) - Friday, 14 February 2020, 23:07 GMT
Mesa 19.3.4-2 fixes the issue for me.
Comment by Baudouin Feildel (amdg) - Saturday, 15 February 2020, 12:14 GMT
I can confirm mesa 19.3.4-2 fixes the issue for me also. Please note the issue was also affecting GDM on Wayland, not only Xorg.
Comment by cgm999 (cgm999) - Saturday, 15 February 2020, 12:22 GMT
19.3.4-2 Fixes for me as well(Xorg)
Comment by Ioannis Kozanitis (giannis-arch) - Saturday, 15 February 2020, 15:19 GMT
19.3.4-2 Fixes the issue for me as well, (with lxdm)

Loading...