Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65492 - [glibc] [lib32-glibc] sleep: cannot read realtime clock: Invalid argument

Attached to Project: Arch Linux
Opened by Hugo Ferreira (hferreira) - Friday, 14 February 2020, 00:26 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Monday, 17 February 2020, 06:39 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After upgrading glibc to version 2.31-1 the sleep command started throwing out the error:

sleep: cannot read realtime clock: Invalid argument

Downgrading to the previous version "solves" the issue.

Additional info:
* package version: glibc-2.31-1

Steps to reproduce:

Upgrade glibc to 2.31-1.
Do a sleep 0 on the shell
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Monday, 17 February 2020, 06:39 GMT
Reason for closing:  Works for me
Comment by freswa (frederik) - Friday, 14 February 2020, 00:32 GMT
Cannot reproduce. Can you please give us an `uname -a`?
Comment by Max Cole (wrvsrx) - Monday, 17 February 2020, 01:23 GMT
It can be reproduced in WSL 1. Maybe it only happens in WSL.

Loading...