Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#65469 - [firefox] [glibc] firefox 73.0 Widevine plugin crashes

Attached to Project: Arch Linux
Opened by Robert de Jager (blob) - Wednesday, 12 February 2020, 13:20 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 19 February 2020, 09:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Bartłomiej Piotrowski (Barthalion)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No



Since upgrading to firefox 73.0, visiting Netflix results in the yellow top bar with text "The plugin has crashed"

Additional info:
* Firefox 73.0

Steps to reproduce:
log in to netflix (or visit

I have already tried:
- Disabling all extensions / other plugins
- remove .mozilla directory and start from scratch
- launch firefox with environment variable MOZ_DISABLE_GMP_SANDBOX=1 (this one fixes the plugin crash, but sacrifices security)
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 19 February 2020, 09:40 GMT
Reason for closing:  Fixed
Additional comments about closing:  firefox 73.0.1
Comment by Doug Newgard (Scimmia) - Wednesday, 12 February 2020, 13:27 GMT
Comment by Jan Alexander Steffens (heftig) - Wednesday, 12 February 2020, 13:49 GMT
Sandbox: seccomp sandbox violation: pid 122807, tid 122807, syscall 17, args 17 140736668953232 560 9300548 140736668953232 9300548. Killing process.
Comment by Jan Alexander Steffens (heftig) - Wednesday, 12 February 2020, 13:53 GMT Comment by Eli Schwartz (eschwartz) - Wednesday, 12 February 2020, 14:14 GMT
According to the forum threads, there may have been two related changes, one of which is the new syscalls which need to be whitelisted, the other of which is and fixed by two commits which are already in the glibc release tag.

Does our glibc package actually need changes for this, or is it all in whitelisting syscalls in firefox? I think it is the latter.
Comment by god geu (ghodgeuk) - Thursday, 13 February 2020, 21:53 GMT
I don't know what are you waiting for? A patch is available from 24h. For the release of version 73.0.1.
You put them in trouble, you have to get to work.

How is it even possible that nobody in Mozilla tests such things, although it is known for two months that the changes made to glibc will cause problems with sandbox.
Comment by Eli Schwartz (eschwartz) - Thursday, 13 February 2020, 22:03 GMT
There is no firefox 73.0.1 release available upstream, so I have no clue what you are talking about and we obviously cannot upgrade to it.

What patch is "available from 24h"? It has not been linked here on this ticket, if you want to be useful you can actually specify what you are talking about and we can maybe make some progress.

If you're just here to act insulting, please don't. Nobody here is deliberately waiting to delay fixes for stuff. Sometimes people don't have time to take care of things within minutes of the things they don't know about, though.
Comment by Jan Alexander Steffens (heftig) - Thursday, 13 February 2020, 22:31 GMT
I just don't consider this pressing enough to rush out a release with the patch from; I can patch 73.0.1 if Mozilla doesn't uplift it in time.
Comment by Sven (skoehler) - Friday, 14 February 2020, 20:48 GMT Comment by god geu (ghodgeuk) - Saturday, 15 February 2020, 18:19 GMT
Fortunately, Firefox releases are regular.
It will not be the same as with GNU make that users will have to wait three years to correct a significant error (there were also lucky users of other distributions who were saved from the delay).
The conclusion of reporting software bugs in Archlinux does not make much sense, except for the informational dimension (users do not expect this).

Users wait for self-repair!!!

As a reminder, it is not Mozilla updated glibc in Archlinux (it should still be waiting in testing).
Comment by Alexandr Oleynikov (citrusalex) - Saturday, 15 February 2020, 22:39 GMT
If anyone needs a build of Firefox with this bug fixed, here:
It's identical to the one from Arch Repositories with the exception of having this patch applied:
With this build, Netflix works for me just fine.
Comment by Daniel Mehrmann (Akusari) - Saturday, 15 February 2020, 22:56 GMT
@god geu There is a simple work around to fix that problem while waiting for an new firefox release!
Downgrade these packages:
glibc 2.31-1 -> 2.30-3
lib32-glibc 2.31-1 -> 2.30-3

and it works again. :-)
Comment by Arch Bug (Arch Bug) - Sunday, 16 February 2020, 09:48 GMT
Risky, but works for me too:

sudo pacman -U /var/cache/pacman/pkg/glibc-2.30-3-x86_64.pkg.tar.xz /var/cache/pacman/pkg/lib32-glibc-2.30-3-x86_64.pkg.tar.xz

Thanks :-)
Comment by Luca Corbatto (targodan) - Wednesday, 19 February 2020, 09:36 GMT
Firefox 73.0.1 seems to have just hit the repos and it fixed it for me.