Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65449 - [qt5-3d] broken build - segfault

Attached to Project: Arch Linux
Opened by bartus (bartoszek) - Monday, 10 February 2020, 20:14 GMT
Last edited by Antonio Rojas (arojas) - Monday, 10 February 2020, 23:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Calling `Qt3DRender::Render::ShaderBuilder::syncFromFrontEnd at /usr/lib/libQt53DRender.so.5`
resoults in a segfoult.

Arch build is broken while wheel install (5.14.1) is working.

Upstream report: https://bugreports.qt.io/browse/PYSIDE-1218

Reproduce steps:
https://asciinema.org/a/fDNAUf3dcv4yX3Lsl14WGYjYS
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 10 February 2020, 23:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt5-3d 5.14.1-2
Comment by bartus (bartoszek) - Monday, 10 February 2020, 20:35 GMT
Perhaps we should use `wheel` instead of building from source in case we can't make it work?
Comment by Antonio Rojas (arojas) - Monday, 10 February 2020, 21:38 GMT
Well this is... interesting. A debug build of qt5-3d doesn't reproduce the crash, so there's no way to get a meaningful backtrace. In any case, this has nothing to do with pyside, the crash is in qt3d.
Comment by Antonio Rojas (arojas) - Monday, 10 February 2020, 23:05 GMT
OK this seems to be some kind of bug in the core gcc package - which fortunately is fixed in testing

Loading...