Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65421 - [espeakup] link to espeak-ng

Attached to Project: Community Packages
Opened by Alexander Epaneshnikov (erik_pro) - Saturday, 08 February 2020, 10:00 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 08 February 2020, 16:01 GMT
Task Type Feature Request
Category Packages
Status Assigned
Assigned To David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

since espeakup requires espeak to work, and espeak conflicts with espeak-ng, it is hard for a blind user to install arch with a graphical interface and still have access to the console.

Additional info:

espeakup 80.2

Steps to reproduce:

# pacman -S espeak-ng
# pacman -S espeakup
This task depends upon

Comment by Doug Newgard (Scimmia) - Saturday, 08 February 2020, 16:02 GMT
Is espeak-ng supported by espeakup?
Comment by Alexander Epaneshnikov (erik_pro) - Saturday, 08 February 2020, 16:55 GMT
yes espeak and espeak-ng is api compatible.
Comment by David Runge (dvzrv) - Wednesday, 01 April 2020, 16:26 GMT
@erik_pro: Thanks for the report.

I'm currently a little hesitant to do just that, because there are issues reported to espeak-ng in regards to espeakup:
https://github.com/espeak-ng/espeak-ng/issues/285
https://github.com/espeak-ng/espeak-ng/issues/463

Would you be able to comment on these?
Comment by Alexander Epaneshnikov (erik_pro) - Wednesday, 01 April 2020, 17:38 GMT
commented on issues.
i can't reproduce this on current espeak-ng from arch-repo and mi own espeakup.
Comment by Daniel M. Capella (polyzen) - Wednesday, 01 April 2020, 17:40 GMT
The espeak and espeak-ng packages no longer conflict. A split package named "espeak-ng-espeak" was created consisting of the conflicting files.
https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/espeak-ng&id=fad932ae596e2659d8a0e306f590d7d2b5cd14a7

@erik_pro, BTW I've been told espeak and espeak-ng are "not fully ABI nor API compatible".

We're also looking into adding MBROLA to the repos to use with espeak-ng and such, so just linking this for future reference:
https://github.com/williamh/espeakup/issues/13

Loading...