Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65395 - Arch Kernel and zen kernel are out of sync with gcc

Attached to Project: Arch Linux
Opened by Steve (Roken) - Wednesday, 05 February 2020, 22:41 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 07 February 2020, 13:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Arch and zen kernels are built with gcc 9.2.1+20200130-1. gcc is now at 9.2.1+20200130-3, and this breaks tho module chain.

Steps to reproduce:

Update testing - reboot.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 07 February 2020, 13:10 GMT
Reason for closing:  Fixed
Comment by Jonas Witschel (diabonas) - Wednesday, 05 February 2020, 23:13 GMT
I cannot reproduce this issue: note that there is no "gcc 9.2.1+20200130-3", the most recent version is 9.2.1+20200130-2 at the moment, the only change from 9.2.1+20200130-1 being that some files conflicting with gcc-d have been removed from gcc-libs ( FS#65384 ).

Are you sure that your initramfs has been updated correctly when upgrading the kernel? What errors are you getting upon reboot?
Comment by loqs (loqs) - Thursday, 06 February 2020, 00:03 GMT

Loading...