Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65382 - Pulseaudio not working on 5.5.x series kernels

Attached to Project: Arch Linux
Opened by Jouni Rinne (cyberpunkrocker) - Wednesday, 05 February 2020, 06:50 GMT
Last edited by freswa (frederik) - Tuesday, 11 February 2020, 23:08 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description: This started originally as task  FS#65361 . It was supposedly fixed by linux-5.5.1.arch2-1-x86_64, unfortunately not for me, because pulseaudio does not work. It reports NO real output devices whatsoever, only a 'fake output device'. I've been unable to produce any sound via pulseaudio on any 5.5 series kernels. No issues with 5.4 series kernels or earlier.


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  freswa (frederik)
Tuesday, 11 February 2020, 23:08 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#64720 
Comment by liuerfire (liuerfire) - Wednesday, 05 February 2020, 10:52 GMT
same issue. downgrade kernel to 5.4.8 fixed it.
Comment by Xabier Larrakoetxea (slok) - Thursday, 06 February 2020, 07:47 GMT
The same issue here and also suspension stopped working after the upgrade, on a Lenovo Thinkpad X1 Carbon (Gen 7).

Downgrading to a 5.4.x Kernel solved the issue.
Comment by Yifan ZHU (schrodinger) - Tuesday, 11 February 2020, 05:27 GMT
I guess downgrading is not needed. Adding snd_hda_intel.dmic_detect=0 still works on my PC. This is discussed already before. (in #64720)
Comment by Sergey (ArchXUser) - Tuesday, 11 February 2020, 06:56 GMT
Adding snd_hda_intel.dmic_detect=0 worked for me, too. Dell Vostro 5590 (i5)
Comment by liuerfire (liuerfire) - Tuesday, 11 February 2020, 08:51 GMT
Adding snd_hda_intel.dmic_detect=0 solves the sound problem. However suspension is still broken.

Loading...