Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65378 - [powerdevil] Use CMake generator agnostic PKGBUILD

Attached to Project: Arch Linux
Opened by Daan De Meyer (DaanDeMeyer) - Tuesday, 04 February 2020, 20:43 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 04 February 2020, 20:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

```
build() {
cmake \
-S "${_pkgname}-${pkgver}" \
-B build \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_LIBEXECDIR=lib \
-DBUILD_TESTING=OFF
cmake --build build
}

package() {
DESTDIR="${pkgdir}" cmake --install build
}
```

The advantage is that this works with any CMake generator (more specifically, Ninja) instead of only with make. It's also shorter and more idiomatic CMake usage.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 04 February 2020, 20:46 GMT
Reason for closing:  Not a bug

Loading...