Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65360 - [linux] New Main Linux Arch Kernel (NOT Linux-mainline, although that's broken too) iwlwifi Broken

Attached to Project: Arch Linux
Opened by Matt McDonald (gardotd426) - Monday, 03 February 2020, 19:18 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 03 February 2020, 19:21 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
iwlwifi is broken on linux-5.5.1-arch-1-1. I know this is an upstream bug, but I thought surely the reason why it was taking so long for it to hit the Arch repos was QA which would include fixing this bug, as there's a readily available patch available. However, that's not the case, and one of the biggest wifi adapters is broken in Arch Linux's main kernel. Thank god I have a custom kernel installed with the patch, but that's the only one I can use right now. linux-mainline has the same bug, linux-zen ALSO has the same bug, and linux-lts is incompatible with my RX 5600 XT. Please, please fix this right away. Since this is a binary package, I'm unable to apply the patch myself, even though I have a copy of it. I can't figure out how to compile a kernel from scratch (every time I try, the modules don't get loaded for some reason no matter which instructions I follow), but even if I could, that's not the point. Wifi should work in 2020 on mainline hardware from Intel of all places.

Wifi adapter: Dual Band Wireless-AC 3168NGW

bugzilla kernel bug thread with patch linked in thread: https://bugzilla.kernel.org/show_bug.cgi?id=206329

I have attached a copy of the patch, it's the exact same one available

Steps to reproduce:
Have a 3168NGW adapter from Intel.
Be running linux-5.5.1-arch-1-1.
Wifi doesn't work at all.

Again, I know the patch is available, but it can't be applied to linux-5.5.1-arch-1-1, and often it can take weeks for kernel updates.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 03 February 2020, 19:21 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#65359 

Loading...