Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65357 - [wireguard-lts] Add exact kernel version to linux-lts dependency

Attached to Project: Arch Linux
Opened by Endre Szabo (endre) - Monday, 03 February 2020, 13:24 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 03 February 2020, 14:17 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Please add exact version to kernel dependency so that we can know which version this package was built against and thus, depends on.

My sample 'diff' on a PKGBUILD would be:

- depends=('linux-lts')
+ depends=('linux-lts=4.19.98-1')

archzfs does this and we can work with it very nicely to make a repo with packages of equivalent kernel version dependencies.

$ pacman -Si wireguard-lts | grep ^Dep
Depends On : linux-lts
$ pacman -Si zfs-linux-lts | grep ^Dep
Depends On : kmod zfs-utils=0.8.3 linux-lts=4.19.98-1
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 03 February 2020, 14:17 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Partial updates are not supported.
Comment by Endre Szabo (endre) - Monday, 03 February 2020, 13:27 GMT
Ah I did not look further in the PKGBUILD. The change is more easier to make if we swap the two lines:

- depends=('linux-lts')
- _kernver="$(</usr/src/linux-lts/version)"
+ _kernver="$(</usr/src/linux-lts/version)"
+ depends=("linux-lts=${_kernver}")
Comment by Eli Schwartz (eschwartz) - Monday, 03 February 2020, 14:16 GMT
Archzfs is the last place I would look to for good advice on how to package anything.

Maintaining the version by hand is a painful waste of time when arch doesn't support partial updates, which means that it becomes harder to release timely updates. Evaluating the version in a manner that breaks --printsrcinfo and makes it impossible to properly lint invalid dependency values is something we've explicitly moved away from and doesn't work on all versions of pacman, see  FS#58776  for details.

Loading...