Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65351 - systemd: Request to backport btrfs swapfile hibernation fixes

Attached to Project: Arch Linux
Opened by Zach Smith (zaxmyth) - Saturday, 01 February 2020, 20:39 GMT
Last edited by Christian Hesse (eworm) - Thursday, 23 April 2020, 05:22 GMT
Task Type Support Request
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Christian Hesse (eworm)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Please consider backporting the following patches which fix a Btrfs swapfile hibernation regression introduced in 244. These patches enable proper hibernation for Btrfs + swapfile users.

# systemd-sleep: always attempt hibernation if configured
52133271a7b3d76bed6d957f75371030193f5282

# shared/sleep: use stat() instead of open()+fstat() in one place
e9f0c5d08c6590c37d92dbdcf402706613d6daeb

# shared/sleep-config: make swap detection stricter again
8efc2c1608afa5bf8d857d4ea335c88cf6b6192b

# shared/sleep-config: do not ignore resume_offset when resume not set
8f817cb888ccdb7625b6c6b50bf0f6c6ff12507c


Additional info:

Upstream bug:
"Systemd 244 Hibernation failed due to sys/power/resume and /sys/power/resume_offset has no matching entry in /proc/swaps"
https://github.com/systemd/systemd/issues/14249


Suggested PKGBUILD patch: https://pastebin.com/vz8nqJmv

diff --git a/trunk/PKGBUILD b/trunk/PKGBUILD
index d48b65d..bd721c2 100644
--- a/trunk/PKGBUILD
+++ b/trunk/PKGBUILD
@@ -60,6 +60,14 @@ sha512sums=('SKIP'
'209b01b044877cc986757fa4009a92ea98f480306c2530075d153203c3cd2b3afccab6aacc1453dee8857991e04270572f1700310705d7a0f4d5bed27fab8c67')

_backports=(
+ # systemd-sleep: always attempt hibernation if configured
+ '52133271a7b3d76bed6d957f75371030193f5282'
+ # shared/sleep: use stat() instead of open()+fstat() in one place
+ 'e9f0c5d08c6590c37d92dbdcf402706613d6daeb'
+ # shared/sleep-config: make swap detection stricter again
+ '8efc2c1608afa5bf8d857d4ea335c88cf6b6192b'
+ # shared/sleep-config: do not ignore resume_offset when resume not set
+ '8f817cb888ccdb7625b6c6b50bf0f6c6ff12507c'
)

_reverts=(

This task depends upon

Closed by  Christian Hesse (eworm)
Thursday, 23 April 2020, 05:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd 245-1
Comment by Zach Smith (zaxmyth) - Thursday, 23 April 2020, 04:31 GMT
I think this can be closed now that 245 is out.

Loading...