Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65255 - [nextcloud]18.0.0-1 Command "upgrade" is not defined.

Attached to Project: Community Packages
Opened by Moth (Moth) - Friday, 24 January 2020, 14:10 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
Wanted to install Nextcloud. Related to  FS#65254 : https://bugs.archlinux.org/task/65254?project=5&string=nextcloud . To work around the latter, I have changed permission mode of `/usr/share/webapps/nextcloud/apps/` by applying `sudo chmod 755 /usr/share/webapps/nextcloud/apps`, but now I have this new bug.

$ sudo pacman -S nextcloud

...

Packages (1) nextcloud-18.0.0-1

...

Nextcloud is not installed - only a limited number of commands are available


Command "upgrade" is not defined.


error: command failed to execute correctly

Additional info:
* package version: nextcloud-18.0.0-1

Steps to reproduce:
$ sudo pacman -S nextcloud
This task depends upon

Comment by Harald Koch (hkoch) - Thursday, 20 February 2020, 14:02 GMT
I don't know if it is related to your issue, but the upgrade to nextcloud-18.0.0-1 overwrote my config file /etc/webapps/nextcloud/config/config.php - I had to restore from a backup to get nextcloud running again.

Loading...