Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65241 - [firefox][chromium] Location services error

Attached to Project: Arch Linux
Opened by Yigit Ates (yigitates) - Wednesday, 22 January 2020, 21:55 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 09 August 2020, 04:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: Location services don't work.

Additional info:
* Firefox 72.0.2
* https://bugzilla.mozilla.org/show_bug.cgi?id=1610306

Steps to reproduce:

Go to Google Maps, Yandex Maps, OpenStreetMap etc. and try to detect your exact location. OpenStreetMap throws "Geolocation error: Unknown error acquiring position" error.

According to bug report, there is no problem on Mozilla's builds. So maybe our packager can fix it on our own build.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 09 August 2020, 04:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  Working again since July 29. It might break again in the future but there's not much we can do about that.
Comment by Jan Alexander Steffens (heftig) - Sunday, 26 January 2020, 15:49 GMT
Also affects Chromium. Tested using https://browserleaks.com/geo

Our quota has been exceeded.

The network panel in Firefox's browser toolbox shows a failed geolocation request:

{
"error": {
"code": 429,
"message": "Quota exceeded for quota group 'default' and limit 'Requests per day' of service 'geolocation.googleapis.com' for consumer 'project_number:413772536636'.",
"errors": [
{
"message": "Quota exceeded for quota group 'default' and limit 'Requests per day' of service 'geolocation.googleapis.com' for consumer 'project_number:413772536636'.",
"domain": "global",
"reason": "rateLimitExceeded"
}
],
"status": "RESOURCE_EXHAUSTED"
}
}
Comment by Balló György (City-busz) - Sunday, 01 March 2020, 19:59 GMT
A workaround for Firefox is to switch to the Mozilla Location Service. I added this information to the wiki:
https://wiki.archlinux.org/index.php/Firefox#Geolocation_does_not_work
Comment by Yigit Ates (yigitates) - Monday, 02 March 2020, 09:30 GMT
Mozilla Location Service is not accurate unfortunately. It can't detect exact location, error margin is too high.

Loading...