Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65203 - [ceph] Missing dependency python-cmd2

Attached to Project: Community Packages
Opened by Chih-Hsuan Yen (yan12125) - Sunday, 19 January 2020, 10:47 GMT
Last edited by Thore Bödecker (foxxx0) - Tuesday, 04 February 2020, 17:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Thore Bödecker (foxxx0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

$ cephfs-shell
Traceback (most recent call last):
File "/usr/bin/cephfs-shell", line 8, in <module>
from cmd2 import Cmd
ModuleNotFoundError: No module named 'cmd2'

By the way, /usr/lib/python3.8/site-packages/cephfs_shell-0.0.1-py3.8.egg-info seems to better be in community/ceph rather than community/ceph-libs as /usr/bin/cephfs-shell is in ceph.

I noticed this as `pip check` complains:

$ pip check
cephfs-shell 0.0.1 requires cmd2, which is not installed.

I don't use ceph by myself.

Additional info:
ceph 14.2.6-1

Steps to reproduce:
1. Install ceph but not python-cmd2
2. Run cephfs-shell
This task depends upon

Closed by  Thore Bödecker (foxxx0)
Tuesday, 04 February 2020, 17:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  added missing python-cmd2 dep, fixed as of ceph-14.2.7-1
Comment by Thore Bödecker (foxxx0) - Tuesday, 04 February 2020, 17:28 GMT
libs belong into the -libs split package, whether they are directly needed there or not, that's the purpose of it so other things can depend only on the much smaller -libs package

Loading...