Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65173 - [dotnet-sdk] Using strict and comparable version-based provision and dependencies

Attached to Project: Community Packages
Opened by Nguyễn Chính Hữu (huupoke12) - Thursday, 16 January 2020, 02:41 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 16 January 2020, 06:05 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I think this should use a comparable version-based provision and dependencies like the official jre-openjdk-headless, jre-openjdk, jdk-openjdk packages are using (dotnet-sdk=3.1 instead of dotnet-sdk-3.1). And I think it should be more strict in dependencies and their version (like the openjdk) since if installing dotnet-host 3.1.0-sdk100 and dotnet-runtime 3.1.0-sdk100 but install dotnet-sdk 3.1.1-sdk101, the SDK can't be used and complain about missing runtime, but the dependencies mentioned in the packages are still satisfied.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 16 January 2020, 06:05 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Partial updates are not supported

Loading...