Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65136 - [monero] monero-wallet-cli not compiled with Trezor support

Attached to Project: Community Packages
Opened by Jim Johnson (JimmyJammy) - Tuesday, 14 January 2020, 02:57 GMT
Last edited by kpcyrd (kpcyrd) - Friday, 20 March 2020, 14:48 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To kpcyrd (kpcyrd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

The monero-wallet-cli binary from the Arch community repository does not support Trezor devices, while the one downloaded from getmonero.org does.

Additional info:
* package version 0.15.0.1-3

Steps to reproduce:
1) Install the monero package
2) Install trezord-go from the AUR
3) Run monero-wallet-cli --hw-device Trezor --generate-from-device MoneroWallet with the Trezor device plugged in and unlocked

The process exits with 'Error: failed to generate new wallet: device not found: Trezor'

The log file shows:
ERROR serialization src/device/device.cpp:86 Device not found in registry: 'Trezor'. Known devices:
ERROR serialization src/device/device.cpp:88 - Ledger
ERROR serialization src/device/device.cpp:88 - default


Running the same command using the downloaded binary from getmonero.org successfully creates a new wallet.
The log file shows:
DEBUG device.trezor src/device_trezor/device_trezor_base.cpp:116 Enumerating Trezor devices...
[...]
TRACE device.trezor.transport src/device_trezor/trezor/transport.cpp:894 Libusb devices: x
TRACE device.trezor.transport src/device_trezor/trezor/transport.cpp:909 Found Trezor device: xxxx-xxxx
This task depends upon

Closed by  kpcyrd (kpcyrd)
Friday, 20 March 2020, 14:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 0.15.0.5-1
Comment by kpcyrd (kpcyrd) - Tuesday, 14 January 2020, 20:00 GMT
Please retry with 0.15.0.1-4

Unfortunately I can't test it myself since I'm missing the hardware.
Comment by Jim Johnson (JimmyJammy) - Tuesday, 14 January 2020, 21:51 GMT
Now I'm getting:
monero-wallet-cli: error while loading shared libraries: libprotobuf.so.22: cannot open shared object file: No such file or directory

After installing the protobuf package, monero-wallet-cli works with Trezor, so now it's just a problem with linking the library.

Maybe you should add hidapi and protobuf as optional dependencies for hw wallet support?

EDIT: The package doesn't work without protobuf, so it needs to be added as a proper dependency.

Loading...