Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#65134 - Invoke pacman without any sudo timeout

Attached to Project: Pacman
Opened by mirh (mirh) - Tuesday, 14 January 2020, 00:11 GMT
Last edited by Allan McRae (Allan) - Tuesday, 14 January 2020, 05:35 GMT
Task Type Bug Report
Category makepkg
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version 5.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
I, for one, think it is annoying that scripts can fail simply because you went to the bathroom or something like that.
And editing passwd_timeout in the sudoers file seems a bit too much.
Could you have sudo execute with "-T 0" parameter?

Steps to Reproduce:
Do anything that triggers run_pacman (such as using --syncdeps with a package where you are missing something)
Wait 5 minutes.
See the thing fail.
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 14 January 2020, 05:35 GMT
Reason for closing:  Won't implement
Comment by Eli Schwartz (eschwartz) - Tuesday, 14 January 2020, 00:21 GMT
Why not just set a passwd_timeout that applies specifically to the pacman command?

Loading...