Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65131 - plasma-wayland-desktop plasmawayand.desktop file ignored by GDM if plasma.destkop present

Attached to Project: Arch Linux
Opened by Gašper Ažman (atomicity) - Monday, 13 January 2020, 14:25 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 16 January 2020, 20:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: GDM deduplicates plasmawayland.desktop and plasma.desktop because they have the same name strings.

Package versions:
extra/gdm 3.34.1-1 (gdm)
extra/plasma-wayland-session 5.17.5-1 (plasmawayland.desktop)
extra/plasma-workspace 5.17.5-1 (plasma.desktop)

Exhibited behaviour:
The problem is that gdm only shows the plasma.desktop entry (and the wayland gnome desktop entry, which confirms it does scan /usr/share/wayland-clients/).

Desired behaviour:
It should show both entries.

Some more detail: https://www.reddit.com/r/gnome/comments/dim3fo/gdm_does_not_see_the_plasma_wayland_session/f5nyjgi/

The clue is that apparently, gdm deduplicates entries with the same name, thus hiding the wayland plasma session.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 16 January 2020, 20:12 GMT
Reason for closing:  Upstream
Additional comments about closing:  Will be fixed in Plasma 5.18

Loading...