Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65128 - [dotnet-sdk] Unrecognized RuntimeIdentifier 'arch-x64'

Attached to Project: Community Packages
Opened by Florian Maunier (fmauNeko) - Monday, 13 January 2020, 11:15 GMT
Last edited by Maxime Gauduin (Alucryd) - Monday, 20 January 2020, 08:50 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:
The 'arch-x64' RuntimeIdentifier isn't recognized.

Apparently the patch that adds it to corefx has been delayed to the 5.0 milestone (https://github.com/dotnet/corefx/pull/41750)

In the meantime, patching /usr/share/dotnet/sdk/3.1.100/RuntimeIdentifierGraph.json manually is a valid workaround. Joined patch does just that.

Steps to reproduce:
1 - 'dotnet restore' any project
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Monday, 20 January 2020, 08:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.1.0.sdk100-2
Comment by Joost Molenaar (j0057_1) - Monday, 13 January 2020, 20:58 GMT
Confirming that the bug exists and that the patch resolves it.

An easier repro is `cd /tmp; dotnet new console --name test`.
Comment by Brad M. Wilson (ptrxyz) - Monday, 13 January 2020, 21:08 GMT
Can also confirm this bug. The fix seems good :)
Comment by Fly (flyznex) - Tuesday, 14 January 2020, 03:11 GMT
Confirm that bug exists. The patch working good.
Comment by Josh Kropf (jiggak) - Thursday, 16 January 2020, 03:45 GMT
After applying that runtime identifier patch I can run package restores and even run console apps, but attempting to run web apps just fails with the error:

It was not possible to find any compatible framework version
The framework 'Microsoft.AspNetCore.App', version '3.1.0' was not found.
- No frameworks were found.

Curious if others have the same issue. Easiest way to reproduce is

dotnet new webapi
dotnet restore
dotnet run
Comment by Josh Kropf (jiggak) - Thursday, 16 January 2020, 04:31 GMT
Derp. I'm an idiot. I see there are separate packages now for the aspnet-runtime.
Comment by heapify man (heapifyman) - Friday, 17 January 2020, 10:16 GMT
Same problem here with dotnet-sdk 3.1.0.sdk100-1 from community repo (https://www.archlinux.org/packages/community/x86_64/dotnet-sdk/)

Problem disappears when using dotnet-sdk-bin 3.1.1.sdk101-2 from AUR (https://aur.archlinux.org/packages/dotnet-sdk-bin/).
Even though "RuntimeIdentifierGraph.json" still does not contain anything related to "arch" or "arch-x64".
Comment by Florian Maunier (fmauNeko) - Friday, 17 January 2020, 14:50 GMT
That's because dotnet-sdk-bin is generated from the Microsoft-provided linux binaries, which use 'linux-x64' as RID instead of 'arch-x64' for our custom source-built release.
Comment by Maxime Gauduin (Alucryd) - Friday, 17 January 2020, 19:54 GMT
@fmauNeko Thanks for the patch, it was easier to just backport the pull request though so I did just that. It's working fine here now.
Comment by Fagan Saidzade (saidfgn) - Saturday, 18 January 2020, 06:45 GMT
Solved the same problem on Manjaro 18.1.5
Comment by Florian Maunier (fmauNeko) - Monday, 20 January 2020, 08:44 GMT
Looks good to me with 3.1.0.sdk100-2.
I guess that issue can be closed.

Loading...