Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65097 - [gitlab] API is not accessible

Attached to Project: Community Packages
Opened by Harm Endres (stingA0815) - Thursday, 09 January 2020, 17:55 GMT
Last edited by Anatol Pomozov (anatolik) - Friday, 10 January 2020, 23:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Anatol Pomozov (anatolik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

API is not accessible

Additional info:
* package version(s)
```
gitlab 12.6.2-2
gitlab-gitaly 1.78.0-2
gitlab-runner 12.6.0-1
gitlab-shell 2:10.3.0-2
gitlab-workhorse 8.18.0-1
```
* config and/or log files etc.

production.log
```
Started POST "/api/v4/jobs/request" for 1.2.3.4 at 2020-01-09 18:48:57 +0100

ArgumentError (wrong number of arguments (given 3, expected 1..2)):

lib/gitlab/request_profiler/middleware.rb:17:in `call'
lib/gitlab/middleware/go.rb:20:in `call'
lib/gitlab/etag_caching/middleware.rb:13:in `call'
lib/gitlab/middleware/correlation_id.rb:16:in `block in call'
lib/gitlab/middleware/correlation_id.rb:15:in `call'
lib/gitlab/middleware/multipart.rb:117:in `call'
lib/gitlab/middleware/read_only/controller.rb:48:in `call'
lib/gitlab/middleware/read_only.rb:18:in `call'
lib/gitlab/middleware/basic_health_check.rb:25:in `call'
lib/gitlab/request_context.rb:32:in `call'
config/initializers/fix_local_cache_middleware.rb:9:in `call'
lib/gitlab/metrics/requests_rack_middleware.rb:49:in `call'
lib/gitlab/middleware/release_env.rb:12:in `call'
```
gitlab-shell.log
```
time="2020-01-09T18:45:00+01:00" level=error msg="Call failed" body="<!DOCTYPE html>\n<html>\n<head>\n <meta content=\"width=device-width, initial-scale=1, maximum-scale=1\" name=\"viewport\">\n <title>Something went wrong (500)</title>\n <style>\n body {\n color: #666;\n text-align: center;\n font-family: \"Helvetica Neue\", Helvetica, Arial, sans-serif;\n margin: auto;\n font-size: 14px;\n }\n\n h1 {\n font-size: 56px;\n line-height: 100px;\n font-weight: 400;\n color: #456;\n }\n\n h2 {\n font-size: 24px;\n color: #666;\n line-height: 1.5em;\n }\n\n h3 {\n color: #456;\n font-size: 20px;\n font-weight: 400;\n line-height: 28px;\n }\n\n hr {\n max-width: 800px;\n margin: 18px auto;\n border: 0;\n border-top: 1px solid #EEE;\n border-bottom: 1px solid white;\n }\n\n img {\n max-width: 40vw;\n display: block;\n margin: 40px auto;\n }\n\n a {\n line-height: 100px;\n font-weight: 400;\n color: #4A8BEE;\n font-size: 18px;\n text-decoration: none;\n }\n\n .container {\n margin: auto 20px;\n }\n\n .go-back {\n display: none;\n }\n\n </style>\n</head>\n\n<body>\n <a href=\"/\">\n <img src=\"data:image/svg+xml;base64,PHN2ZyB3aWR0aD0iMjEwIiBoZWlnaHQ9IjIxMCIgdmlld0JveD0iMCAwIDIxMCAyMTAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyI+CiAgPHBhdGggZD0iTTEwNS4wNjE0IDIwMy42NTVsMzguNjQtMTE4LjkyMWgtNzcuMjhsMzguNjQgMTE4LjkyMXoiIGZpbGw9IiNlMjQzMjkiLz4KICA8cGF0aCBkPSJNMTA1LjA2MTQgMjAzLjY1NDhsLTM4LjY0LTExOC45MjFoLTU0LjE1M2w5Mi43OTMgMTE4LjkyMXoiIGZpbGw9IiNmYzZkMjYiLz4KICA8cGF0aCBkPSJNMTIuMjY4NSA4NC43MzQxbC0xMS43NDIgMzYuMTM5Yy0xLjA3MSAzLjI5Ni4xMDIgNi45MDcgMi45MDYgOC45NDRsMTAxLjYyOSA3My44MzgtOTIuNzkzLTExOC45MjF6IiBmaWxsPSIjZmNhMzI2Ii8+CiAgPHBhdGggZD0iTTEyLjI2ODUgODQuNzM0Mmg1NC4xNTNsLTIzLjI3My03MS42MjVjLTEuMTk3LTMuNjg2LTYuNDExLTMuNjg1LTcuNjA4IDBsLTIzLjI3MiA3MS42MjV6IiBmaWxsPSIjZTI0MzI5Ii8+CiAgPHBhdGggZD0iTTEwNS4wNjE0IDIwMy42NTQ4bDM4LjY0LTExOC45MjFoNTQuMTUzbC05Mi43OTMgMTE4LjkyMXoiIGZpbGw9IiNmYzZkMjYiLz4KICA8cGF0aCBkPSJNMTk3Ljg1NDQgODQuNzM0MWwxMS43NDIgMzYuMTM5YzEuMDcxIDMuMjk2LS4xMDIgNi45MDctMi45MDYgOC45NDRsLTEwMS42MjkgNzMuODM4IDkyLjc5My0xMTguOTIxeiIgZmlsbD0iI2ZjYTMyNiIvPgogIDxwYXRoIGQ9Ik0xOTcuODU0NCA4NC43MzQyaC01NC4xNTNsMjMuMjczLTcxLjYyNWMxLjE5Ny0zLjY4NiA2LjQxMS0zLjY4NSA3LjYwOCAwbDIzLjI3MiA3MS42MjV6IiBmaWxsPSIjZTI0MzI5Ii8+Cjwvc3ZnPgo=\"\n alt=\"GitLab Logo\" />\n </a>\n <h1>\n 500\n </h1>\n <div class=\"container\">\n <h3>Whoops, something went wrong on our end.</h3>\n <hr />\n <p>Try refreshing the page, or going back and attempting the action again.</p>\n <p>Please contact your GitLab administrator if this problem persists.</p>\n <a href=\"javascript:history.back()\" class=\"js-go-back go-back\">Go back</a>\n </div>\n <script>\n (function () {\n var goBack = document.querySelector('.js-go-back');\n\n if (history.length > 1) {\n goBack.style.display = 'inline';\n }\n })();\n </script>\n</body>\n</html>\n" code=500 method=POST pid=1171 url="http://localhost:8080/api/v4/internal/allowed"
```



* link to upstream bug report, if any

Steps to reproduce:

Try to edit a file in the web interface

This task depends upon

Closed by  Anatol Pomozov (anatolik)
Friday, 10 January 2020, 23:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  gitlab-12.6.2-3
Comment by Federico Ravasio (razielgn) - Thursday, 09 January 2020, 18:03 GMT
It doesn't seem that gitlab is already compatible with ruby >=2.7. See https://gitlab.com/gitlab-org/gitlab-foss/blob/master/.ruby-version
Comment by Harm Endres (stingA0815) - Thursday, 09 January 2020, 18:08 GMT
Thank you for the hint, might be the reason!

~~~
[2020-01-09T18:06:54+0100] [ALPM] installed ruby (2.7.0-1)
~~~
Comment by Federico Ravasio (razielgn) - Thursday, 09 January 2020, 18:14 GMT
12.5.4-1 was still using the ruby2.5 package. Then, from 12.6.0-1 it switched to just ruby, that at the time was 2.6.5.
A solution could be to do the same thing, but with a ruby2.6 package.
Comment by Harm Endres (stingA0815) - Thursday, 09 January 2020, 18:27 GMT
Thanks for the advice, a downgrade fixed the problem
Comment by DeLord (DeLord) - Friday, 10 January 2020, 13:02 GMT
What did you downgrade? Ruby?
Comment by Harm Endres (stingA0815) - Friday, 10 January 2020, 13:25 GMT
I've downgraded GitLab, the web interface problem is gone. I'm facing issues with the gitlab-shell, but I'm not sure if they are related to this topic. I need some time to dig deeper into it.
Comment by Anatol Pomozov (anatolik) - Friday, 10 January 2020, 23:28 GMT
It some weird ruby 2.7 issue, it is not clear what happens here https://gitlab.com/groups/gitlab-org/-/epics/2380

The version with the workaround is released as gitlab-12.6.2-3. Please check it.

Loading...