Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65072 - [espeak-ng] `provides=(espeak="$pkgver")` missing, breaking dependencies.

Attached to Project: Community Packages
Opened by Oid Maps (dreieck) - Tuesday, 07 January 2020, 12:38 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 07 January 2020, 12:59 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

In the transition from

espeak-ng, version 1.49.2-6

to

espeak-ng, version 1.50-1

the `provides`-entry for `espeak` has disappeared, which breaks dependencies.


Additional info:
* package version(s): At least 1.50-1, not 1.49.2-6 and older.

Steps to reproduce:

1. Have `espeak-ng`, version 1.49.2-6 or older installed, which provides the `espeak`-dependency.
2. Have some package installed that depends on `espeak`, e.g. `gst-plugins-espeak`.
3. Upgrade `espeak-ng` to version 1.50-1.
4. Observe that `pacman` fails with
:: installing espeak-ng (1.50-1) breaks dependency 'espeak' required by gst-plugins-espeak
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 07 January 2020, 12:59 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Explicitly dropped in https://git.archlinux.org/svntogit/commu nity.git/commit/trunk?h=packages/espeak- ng&id=74f13d68cb808be0d6dd3b5e2b43dd 7416c0824c FOR A REASON

Loading...