Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65062 - [node-gyp] node-gyp 6.0.1-1 broken with semver v7

Attached to Project: Community Packages
Opened by Freya Gentz (zegentz) - Monday, 06 January 2020, 04:09 GMT
Last edited by David Runge (dvzrv) - Friday, 17 January 2020, 10:11 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Please remove the following from the PKGBUILD to fix this bug:
```
# Experimental dedup
rm -r "$pkgdir"/usr/lib/node_modules/$pkgname/node_modules/semver
```

Alternatively, apply the patch which is available here: https://github.com/nodejs/node-gyp/issues/2005#issuecomment-569586680

Thanks,

Freya
This task depends upon

Comment by Felix Yan (felixonmars) - Sunday, 08 March 2020, 10:08 GMT
Sorry for the delay. Seems like already fixed in node-gyp 6.1.0-1?

Loading...