Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#65058 - Add option to skip size confirmation but not everything like --noconfirm

Attached to Project: Pacman
Opened by Volker Weißmann (volker_weissmann) - Sunday, 05 January 2020, 15:46 GMT
Last edited by Allan McRae (Allan) - Sunday, 05 January 2020, 21:03 GMT
Task Type Feature Request
Category Scripts & Tools
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 5.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

As you know, --noconfirm auto-answers all questions with yes. An option, that auto-answers the size confirmation with yes, but does not answer the other confirmations would be useful for scripts that should halt if there is a problem but not if the package is big.

When I say "the size confirmation", I mean messages like these:

Total Download Size: ... MiB
Total Installed Size: ... MiB

:: Proceed with installation [Y/n]


IMHO you could also completely remove this size confirmation.
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 05 January 2020, 21:03 GMT
Reason for closing:  Won't implement
Comment by Eli Schwartz (eschwartz) - Sunday, 05 January 2020, 15:52 GMT
It's not a "size" confirmation, it's a confirmation of all the details of the update, including warnings about ignored packages, and the full list of updates (potentially the list of updates provided by VerbosePkgLists).

For fully automated scripting use, you may be interested in https://github.com/andrewgregory/pacutils/blob/master/doc/pactrans.pod#prompt-disposition-options

I'm not sure it makes sense to offer a noconfirm option that actually does make you confirm things, since that would cause Pacman to block on input rather than failing gracefully in a way that can be caught via the exit code.
Comment by Volker Weißmann (volker_weissmann) - Sunday, 05 January 2020, 15:56 GMT
I think there should be an option similar to --noconfirm, that auto-confirms the things that aren't "real problems", but asks for confirmation or exits if it encounters a "real problem", like conflicting packages.
Because those prompts for "no real problems" make scripting kind of a nightmare.
Comment by Eli Schwartz (eschwartz) - Sunday, 05 January 2020, 16:13 GMT
Again, if you want actual scripting support, why not use pacutils?

Pacman doesn't really offer a guarantee that it's suitable for scripting, and we've historically been very reluctant to do much work in that regard.

Loading...