Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#65018 - [graphviz] Enable python3 bindings

Attached to Project: Arch Linux
Opened by loqs (loqs) - Thursday, 02 January 2020, 21:06 GMT
Last edited by Gaetan Bisson (vesath) - Saturday, 18 January 2020, 00:54 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The detection of python3 fails due to a cached result from python one detection.
--enable-python=no or the attached patch allow building python 3 bindings.

Additional info:
* graphviz 2.42.3-1
This task depends upon

Closed by  Gaetan Bisson (vesath)
Saturday, 18 January 2020, 00:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  graphviz-2.42.3-2 in [extra]
Comment by Gaetan Bisson (vesath) - Friday, 17 January 2020, 21:57 GMT
I'm a little confused since our current graphviz package already contains:
- /usr/lib/graphviz/python2/libgv_python2.so
- /usr/lib/graphviz/python3/libgv_python3.so
- /usr/lib/python2.7/site-packages/gv.py
- /usr/lib/python3.8/site-packages/gv.py

Could you say a little bit more about what your proposed patch would achieve?
Comment by loqs (loqs) - Saturday, 18 January 2020, 00:39 GMT
I misunderstood from [1] [2] [3] that graphviz did not support python 3 I missed that [4]
shows configure running again with PYTHON=python2 which passes the python 1 check so the cached header check reused for python 3 also passes.
Additionally I should have checked the contents of the package. Sorry for the confusion I caused.
The patch I provided would only help building a package without python2 bindings without needing to pass --enable-python=no to configure.

Could python be added as an optional dependency for the python 3 bindings? I believe it is pulled in at build time as a dependency of mono.

[1] https://bbs.archlinux.org/viewtopic.php?pid=1882783#p1882783
[2] https://gitlab.com/graphviz/graphviz/issues/1626
[3] graphviz-2.42.3-1-x86_64-prepare.log.xz
[4] graphviz-2.42.3-1-x86_64-build.log.xz
Comment by Gaetan Bisson (vesath) - Saturday, 18 January 2020, 00:49 GMT
Thanks for the clarification! I'll add python to the optdepends and also to makedepends for good measure. Cheers.

Loading...