Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#6500 - pacman -Ss and regex

Attached to Project: Pacman
Opened by Scott H (stonecrest) - Wednesday, 28 February 2007, 05:51 GMT
Last edited by Dan McGee (toofishes) - Thursday, 29 November 2007, 18:48 GMT
Task Type Feature Request
Category Backend/Core
Status Closed
Assigned To Aaron Griffin (phrakture)
Dan McGee (toofishes)
Architecture All
Severity Low
Priority Normal
Reported Version 3.0.4
Due in Version 3.1.0
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

It's currently difficult to search for packages like dvd+rw because pacman -Ss treats it like regex. One solution would be to search for both non-regex and regex versions of the string in these instances with the assumption that users won't mind getting more results than they expect (i.e. regex results when they wanted non-regex results), but would be annoyed but not finding what they are searching for.

The ML thread about this can be found here:
http://www.archlinux.org/pipermail/pacman-dev/2007-February/001787.html
This task depends upon

This task blocks these from closing
 FS#8109 - Pacman 3.1 Release Roadmap 
Closed by  Dan McGee (toofishes)
Thursday, 29 November 2007, 18:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  boom, another feature implemented and tested, closing
Comment by Dan McGee (toofishes) - Friday, 09 November 2007, 18:56 GMT
Anyone want to whip up a patch for this? I think we could get it into 3.1.
Comment by Aaron Griffin (phrakture) - Friday, 09 November 2007, 19:22 GMT
Yeah /me tags it for tonight
Comment by Aaron Griffin (phrakture) - Thursday, 15 November 2007, 07:49 GMT Comment by Xavier (shining) - Thursday, 29 November 2007, 18:44 GMT
This has been merged (commit c7879e77a716).
I confirm it works fine (well, pacman -Ss dvd+rw-tools works ;))

Loading...