Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64976 - [Anki] Anki_2.1.15-1 crashes after recent qt upgrade

Attached to Project: Community Packages
Opened by Rick Hurdle (dakotta) - Sunday, 29 December 2019, 03:06 GMT
Last edited by Johannes Löthberg (demize) - Saturday, 09 May 2020, 17:20 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Johannes Löthberg (demize)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I can open anki without error and use it as normal to Study and to Browse. However, when I Add or Edit a card, anki closes with a segmentation fault. Downgrading the qt packages that were upgraded allows anki to work again.

Details attached.

Additional info:
* package version(s) -- anki 2.1.15-1
* config and/or log files etc. -- attached
* link to upstream bug report, if any -- https://anki.tenderapp.com/discussions/ankidesktop/37726-bug-report-anki-2115-1-on-arch-linux-crashes-after-recent-qt-upgrade

Steps to reproduce:

Open anki. Open a deck and select Add. Or Study and then Edit the card you are working with.
   anki.txt (14.5 KiB)
This task depends upon

Closed by  Johannes Löthberg (demize)
Saturday, 09 May 2020, 17:20 GMT
Reason for closing:  Fixed
Comment by Karl Yngve Lervåg (lervag) - Monday, 30 December 2019, 10:47 GMT
I also have the same problem. This bug report did not tag the Anki package, so I hope a moderator/TU could update so that Johannes Löthberg may be notified.
Comment by Johannes Löthberg (demize) - Sunday, 29 March 2020, 01:24 GMT
Can you still reproduce this? Because I never had this issue.
Comment by Johannes Löthberg (demize) - Sunday, 29 March 2020, 01:30 GMT
Also, if you are able to reproduce it, you wouldn't happen to have a 4K monitor?
Comment by Rick Hurdle (dakotta) - Thursday, 09 April 2020, 02:28 GMT
No, I can not still reproduce this error. (And I do not have a 4K monitor).

The problem existed when Qt version increased to 5.14.0-3. I thought I tested it when Qt was updated (to 5.14.1?) but I can't find that in my Pacman log, so maybe I didn't.

After reading your comment, I reinstalled anki 2.1.15-1. It pulled in Qt 5.14.2 (and related files) and the problem seems to be resolved.

Thanks for looking into this. Much appreciated!
Comment by mattia (nTia89) - Sunday, 03 May 2020, 07:57 GMT
with current version everything works
- qt-5.14.2-2
- anki-2.1.23-1

Loading...