Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64973 - [qt5-webengine] Qt Data and Translations paths are missing /usr

Attached to Project: Arch Linux
Opened by Jan Marvin (JanMarvin) - Saturday, 28 December 2019, 13:03 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 30 January 2020, 16:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: A package I frequently build can no longer find Qt folders Data (resources) and Translations (translations). QtWebEngineProcess looks for both folders in "/share/qt" instead of "/usr/share/qt". This can be fixed placing the attached "qt.conf" file in "/usr/lib/qt/libexec".


Additional info:
* package version(s): 5.14.0-1 and iirc 5.13.0-2
* qt.conf attached

Steps to reproduce:
* build and launch rstudio
   qt.conf (0.1 KiB)
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 30 January 2020, 16:32 GMT
Reason for closing:  Upstream
Additional comments about closing:  Doesn't affect any official package
Comment by Antonio Rojas (arojas) - Saturday, 04 January 2020, 12:18 GMT
QLibraryInfo::location(QLibraryInfo::DataPath) returns the correct path, so this looks like rstudio is messing up with paths somehow. No other webengine application is affected by this that I know of.
Comment by Jan Marvin (JanMarvin) - Saturday, 04 January 2020, 13:15 GMT
Thanks for the heads up, I have opened a bug report at rstudio (https://github.com/rstudio/rstudio/issues/5961). I suspected qt5-webengine because placing a qt.conf with rstudio did not help, once qtwebengine was loaded the path was missing /usr once again.

Loading...