Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64968 - linux-hardened hangs at boot after the udev hook with mdadm RAID-1 root

Attached to Project: Arch Linux
Opened by GI Jack (GI_Jack) - Friday, 27 December 2019, 00:41 GMT
Last edited by freswa (frederik) - Friday, 21 February 2020, 14:26 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Attempting to Boot with linux-hardened and software raid 1 using mdadm hangs right after the [udev] hook, last line is

Starting version 244.1-1-arch

Additional info:
* package version(s)

linux-hardened 5.4.6.a-1
mdadm 4.1.-2
mkinitcpio 27-2

* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
Install arch with mdadm software raid-1 on root, and linux-hardened kernel. attempt to boot. encounter hang
This task depends upon

Closed by  freswa (frederik)
Friday, 21 February 2020, 14:26 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#59463
Comment by loqs (loqs) - Saturday, 28 December 2019, 11:24 GMT
The issue is limited to linux-hardened and the system boots without issue using linux 5.4.6.arch3-1?
If you downgrade systemd, systemd-libs, systemd-resolvconf and systemd-sysvcompat does the system boot without issue?
Comment by Stuart Cardall (itoffshore) - Sunday, 12 January 2020, 01:53 GMT
I also have this same error with the initramfs hanging at the udev hook.

It is happening on btrfs encrypted root partitions (both with & without a separate /boot on 2 separate systems)

I'm using systemd 242.153-3 on Manjaro

Comment by Stuart Cardall (itoffshore) - Friday, 31 January 2020, 18:50 GMT
I've tested the recent linux-hardened 5.4 kernels using systemd versions:

242.153-3 (current Manjaro version)
244.1-1 (from Arch Linux archives)

I also tested on systemd 242.153-3 linux-hardened versions:

5.2.18
5.3.18

I also built from AUR:

linux-hardened-git (5.4.15-1-hardened-git-r875616)

& on all of the above I receive the same apparent hang at the [udev] hook (but see disk activity occurring)

I then built from AUR:

linux-hardened-ccs-apparmor 5.4.5.a-1

& was able to successfully boot this kernel & not hang at the [udev] hook

I do not think it is a linux5.4 bug as I can also boot from 5.4.15-2-MANJARO

I'm using amdgpu video driver & think this bug is actually a frozen display as I see
disk activity occurring a few seconds after apparently being hung at [udev] hook.
Comment by Stuart Cardall (itoffshore) - Sunday, 02 February 2020, 13:27 GMT
removing video drivers from MODULES in /etc/mkinitcpio.conf for early KMS shows the boot sequence proceeding further & then appears to hang when amdgpu would be loaded.

this issue appears to be KMS broken for amdgpu in linux-hardened ? (but not linux-hardened-ccs-apparmor)
Comment by loqs (loqs) - Sunday, 02 February 2020, 13:42 GMT
@itoffshore FS#59463
Comment by Stuart Cardall (itoffshore) - Sunday, 02 February 2020, 15:27 GMT
@loqs - yes setting mem_encrypt=off fixes this issue many thanks

Loading...