Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64943 - [allegro4] Header file xalleg.h missing

Attached to Project: Community Packages
Opened by Simon Schuster (noctux) - Monday, 23 December 2019, 13:17 GMT
Last edited by freswa (frederik) - Wednesday, 08 July 2020, 12:34 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

The published package within the repo is missing the header file /usr/include/xalleg.h, which was present in the former releases. When rebuilding the package locally (probably related to some build time checks during prepare?), the header will be present within the package. Probably it is this one in CMakeLists.txt:475:


> option(WANT_X11 "Want X11 support (Unix)" on)
>
> if(ALLEGRO_UNIX AND WANT_X11)
> find_package(X11)
> if(X11_FOUND)
> set(ALLEGRO_WITH_XWINDOWS 1)
> endif()
> endif()

ALLEGRO_WITH_XWINDOWS is later used when generating the install target to decide whether xalleg.h should be included.

Thank you for your time and packaging allegro4 in the first place, and a merry christmas :)

Additional info:
* allegro4 4.4.3.1-2

Steps to reproduce:
* Install allegro4 4.4.3.1-2
* pacman -Ql allegro4 | grep xalleg.h
This task depends upon

Closed by  freswa (frederik)
Wednesday, 08 July 2020, 12:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.4.3.1-3
Comment by rene (demonicmaniac) - Wednesday, 19 February 2020, 22:49 GMT
I've just spent 3 hours debugging stuff in #allegro for somebody with a4 programs crashing only on archlinux in allegro_init() - turns out a simple asp checkout allegro4 and makepkg -si fixed it. So either it is that xalleg.h unconfirmed or some other bug requiring a rebuild for a4 to work properly.
Comment by David Couzelis (drcouzelis) - Monday, 25 May 2020, 01:23 GMT
Thank you for the bug report. This bug bit me in the butt too!

A rebuild / re-installation of allegro4 using the ABS did the trick. :)

Loading...