Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#64932 - makepkg --source does not copy all .install files, breaking offload-build

Attached to Project: Pacman
Opened by Filipe Laíns (FFY00) - Sunday, 22 December 2019, 15:17 GMT
Last edited by Andrew Gregory (andrewgregory) - Thursday, 02 July 2020, 20:11 GMT
Task Type Bug Report
Category makepkg
Status Closed
Assigned To Eli Schwartz (eschwartz)
Architecture All
Severity Low
Priority Normal
Reported Version 5.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/sdrangel I have an .install file for each split package. offload-fails does not copy sdrangel-sse4.1.install, making the build fail.

From the documentation:
> install
> Specifies a special install script that is to be included in the package. This file should reside in the same directory as the PKGBUILD and will be copied into the package by makepkg. It does not need to be included in the source array (e.g., install=$pkgname.install).

There's nothing here that would prevent me to have a sdrangel-sse4.1.install file so it should be legal to do it. Did I miss anything?
This task depends upon

Closed by  Andrew Gregory (andrewgregory)
Thursday, 02 July 2020, 20:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  commit d626a17ef94d79975ff17d04250152ea46aaade3
Comment by Eli Schwartz (eschwartz) - Sunday, 22 December 2019, 15:57 GMT
  • Field changed: Attached to Project (Arch Linux → Pacman)
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Eli Schwartz (eschwartz)
makepkg --source doesn't add it, because extracting variables from a split package() function is hard. This actually works in the special case of makepkg --printsrcinfo, but not makepkg --source, due to quirks in implementation. I'll submit a patch to makepkg which fixes this.
Comment by Eli Schwartz (eschwartz) - Sunday, 22 December 2019, 15:58 GMT Comment by Filipe Laíns (FFY00) - Sunday, 22 December 2019, 16:43 GMT
Thanks!

Loading...