Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64931 - [wayland] Wayland is still utterly unusable, even on Intel GPUs (especially with KDE)

Attached to Project: Arch Linux
Opened by Andrej Podzimek (andrej) - Saturday, 21 December 2019, 22:38 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 21 December 2019, 22:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

When I heard about Wayland back in 2015, I tried it, got a black screen, laughed and moved on. Sadly enough, now that Wayland is being pushed as a "default" or "preferred" option on many distros, the situation is not much better. This problem (and the harm to the free desktop's reputation this has already caused) certainly deserves a closer look (and a bug report). Admittedly, this is mostly an upstream issue. But hey, more than half of my machines run Arch.

Unfortunately, way too many users have already developed a high level of tolerance towards desktop and rendering malfunction typical for Wayland, to the point that most issues don't get reported or even noticed. Just to name a few:

* Strange rendering artifacts appear around all Plasma widgets rather often.
* Multi-display configurations (common nowadays) are quite a disaster to configure; what you configure has nothing in common with what you get after a reboot.
* High DPI screens are a disaster; screen resolution is reported incorrectly by Wayland. Wayland uses a fictional resolution. If you set a scaling factor of 2 on 4K display, you get Full HD resolution reported to applications in certain cases. (Just call plain old xrandr and take a look what it says.)
* As a consequence, random crazy misconfigurations occur (especially in combination with multi-display setups). Sometimes a scaling factor of 2 multiplies your widget size by 4 or more. Changes to the scaling factor yield different results each time.
* Some panel icons appear in high DPI while some are scaled from DPI (in a super-ugly fashion) at random; this issue doesn't exist on X11.
* All Gtk applications are broken in various different ways when used in KDE, which makes them unusable most of the time.
* All Gtk applications flicker randomly while running, sometimes in a way so intrusive that it prevents Qt applications from being used. (Yes, *one* background Gtk window can ruin your entire KDE desktop's usability!)
* Chrome and Chromium are displayed on high DPI in half the physical resolution (!!!); words cannot describe the ugliness of this!
* Thunderbird, surprisingly, has fonts and widgets rendered in full resolution, but shows entirely black dialog boxes. These are mostly important dialog boxes such as CA trustworthiness, various confirmation dialogs etc. This makes Thunderbird unusable.
* The entire desktop is choppy, flickery and feels broken all the time. Alpha-version of a student project; that's the overall impression.

I have systems with Intel, NVidia and AMD GPUs. Wayland is unusuable (yes, utterly u.n.u.s.a.b.l.e) on *all* of them. It doesn't even start on NVidia (dual 5K == quad 2560x2880), so "no issue" there, and it's a total mess on all the other configurations.

Additional info:
* package version(s)

Look, it doesn't really matter. Wayland has *never* worked in the last 5 years, so one version back or forward is unlikely to change that... OK, here we go:

egl-wayland 1.1.4-2
kwayland 5.65.0-2
kwayland-integration 5.17.4-1
plasma-wayland-session 5.17.4-1
qt5-wayland 5.13.2-1
wayland 1.17.0-1
wayland-docs 1.17.0-1
wayland-protocols 1.18-1
waylandpp 0.2.7-1
xorg-server-xwayland 1.20.6-2

* config and/or log files etc.

N/A I don't know where to look; X11 has error logs at least.

* link to upstream bug report, if any

N/A But I bet there are quite a few.

Steps to reproduce:

Use X11 for a couple of hours. Then use Wayland. Uh oh. That's it.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 21 December 2019, 22:40 GMT
Reason for closing:  Not a bug
Additional comments about closing:  You were told before to take your rants elsewhere. Final warning.

Loading...