Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64891 - [paraview] undefined symbol: nc_open

Attached to Project: Community Packages
Opened by Martin Diehl (MartinDiehl) - Thursday, 19 December 2019, 14:41 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Sunday, 05 December 2021, 16:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Currently, the paraview package also provides vtk and its python bindings.
When importing vtk in python, it currently fails with the message

/usr/lib/python3.8/site-packages/vtkmodules/../../../libvtkIOParallelNetCDF-pv5.7.so.1: undefined symbol: nc_open

It works when using the vtk package, but then paraview cannot be installed.

Additional info:
paraview: 5.7.0-3
netcdf: 4.7.3-1
python: 3.8.0-1

Steps to reproduce:
>python
> import vtk
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Sunday, 05 December 2021, 16:16 GMT
Reason for closing:  Upstream
Comment by Chih-Hsuan Yen (yan12125) - Monday, 23 December 2019, 03:30 GMT
Another workaround: LD_PRELOAD=/usr/lib/libnetcdf.so python -c 'import vtk'
Comment by Bruno Pagani (ArchangeGabriel) - Monday, 17 February 2020, 17:37 GMT
This seems to be a linking error, it should be reported upstream I think.
Comment by Martin Diehl (MartinDiehl) - Tuesday, 18 February 2020, 13:38 GMT
many thanks!

Loading...