Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64887 - Gitlab package version 12.5.5-1 does not work with ruby-bundler 2.1.1-1

Attached to Project: Community Packages
Opened by Jacob Bang (julemand101) - Thursday, 19 December 2019, 09:50 GMT
Last edited by Anatol Pomozov (anatolik) - Wednesday, 08 January 2020, 17:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Anatol Pomozov (anatolik)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
This defect is very similar with  FS#61512 . This time it is the combination of gitlab-12.5.5-1 and ruby-bundler-2.1.1-1. After upgrading my system I try run the following command for upgradring the Gitlab deployment which now gives an error:

[root@beta ~]# su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled bundle-2.5 exec rake db:migrate RAILS_ENV=production"
Traceback (most recent call last):
2: from /usr/bin/bundle-2.5:23:in `<main>'
1: from /opt/ruby2.5/lib/ruby/2.5.0/rubygems.rb:303:in `activate_bin_path'
/opt/ruby2.5/lib/ruby/2.5.0/rubygems.rb:284:in `find_spec_for_exe': Could not find 'bundler' (1.17.3) required by your /usr/share/webapps/gitlab/Gemfile.lock. (Gem::GemNotFoundException)
To update to the latest version installed on your system, run `bundle update --bundler`.
To install the missing version, run `gem install bundler:1.17.3`
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Wednesday, 08 January 2020, 17:11 GMT
Reason for closing:  Fixed
Comment by benpro (benproarch) - Saturday, 21 December 2019, 08:39 GMT
Confirmed having the same issue.
```gem-2.5 install bundler:1.17.3``` resolve the issue.

Is it a packaging issue with the bundler gem shipped?
Comment by Alexander Rink (rcvd) - Monday, 23 December 2019, 08:00 GMT
That doesn't resolve it for me, it just gets me into a permission hell...
Comment by Bruno Silva (a36233) - Monday, 23 December 2019, 14:41 GMT
sudo su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled gem-2.5 install bundler:1.17.3"
solved it for me.
Comment by Alexander Rink (rcvd) - Monday, 23 December 2019, 14:48 GMT
@Bruno: I get the following error:

su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled gem-2.5 install bundler:1.17.3"

ERROR: While executing gem ... (Gem::FilePermissionError)
You don't have write permissions for the /opt/ruby2.5/lib/ruby/gems/2.5.0 directory.
Comment by Alexander Rink (rcvd) - Monday, 23 December 2019, 16:30 GMT
Recent update of ruby2.5-bundler fixed this issue for me.
Comment by Jacob Bang (julemand101) - Tuesday, 24 December 2019, 12:06 GMT
I can verify that after updating to ruby2.5-bundler 2.1.2-1 and run the following command:
su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled gem-2.5 install bundler:1.17.3"

That this fixes my issue. I will keep the issue open until there comes a official fix for this issue since the problem still are relevant (that the current version of gitlab does not work with the ruby2.5-bundler version in the package system but the user needs to manually install a compatible version).
Comment by Bruno Silva (a36233) - Thursday, 26 December 2019, 08:53 GMT
sudo su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled gem-2.5 install bundler:1.17.3"
solved it for me.
Comment by Anatol Pomozov (anatolik) - Friday, 27 December 2019, 22:49 GMT
gitlab just moved to ruby-2.6. The issue should be fixed now. Could you please git it a try?
Comment by Jacob Bang (julemand101) - Saturday, 28 December 2019, 08:16 GMT
After removed the previous installed bundler:1.17.3 with:
sudo su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled gem-2.5 uninstall bundler --version 1.17.3"

And tested that I still gets the same error message as described in this bug. I added the community-test repository and updated my gitlab to version 12.6.0-1 and tested the migration again.

The conclusion is that it works now. I want to add that I gets the following two lines in output every time I run the migrate (the first time, the migrate script runs fine and outputs a lot which indicates it works fine. This is just about two lines the migrate script now always return where it before did not return anything if the migrate has already been run):

[root@beta gitlab]# su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled bundle exec rake db:migrate RAILS_ENV=production"
'ErbParser' is ignored.
'RubyParser' is ignored.
Comment by Anatol Pomozov (anatolik) - Saturday, 28 December 2019, 16:13 GMT
Hi Jaco, it is great ti see that 12.6.0 works for you. Please test 12.6.0 as much as you can and let me know the results. I would like to get of ruby 2.5 completely.

As of "'ErbParser' is ignored." - I also see the same message. It seems related to GetText classes but it is not clear why it happens. Does this message cause any issues? If not then I would like to move forward with 12.6.0 release.
Comment by Jacob Bang (julemand101) - Saturday, 28 December 2019, 16:53 GMT
Seems to work fine. I am not any GitLab power user but I have tried different operations (user handling, starting builds, checkout repository) and all seems to be working as expected.
Comment by Anatol Pomozov (anatolik) - Sunday, 29 December 2019, 02:44 GMT
It turned out that

'ErbParser' is ignored.
'RubyParser' is ignored.

is a warning coming from 'gettext' that does not work with newer IRB gem. See https://github.com/ruby-gettext/gettext/issues/64

I downgraded IRB in gitlab r543670 and it seems fixes for me locally. The fix will be available in the next gitlab binary release.
Comment by Jacob Bang (julemand101) - Friday, 03 January 2020, 23:34 GMT
Not sure why but with the recent update on Community-Testing some kind of the error are back.

Relevant packages which are recently updated:
gitlab-gitaly-1.78.0-2 gitlab-shell-2:10.3.0-2 ruby-bundler-2.1.3-1 ruby-rake-13.0.1-2 ruby2.5-bundler-2.1.3-1 gitlab-12.6.2-1

Error when migrating gitlab database:
[root@beta ~]# su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled bundle exec rake db:migrate RAILS_ENV=production"
Traceback (most recent call last):
2: from /usr/bin/bundle:23:in `<main>'
1: from /usr/lib/ruby/2.6.0/rubygems.rb:294:in `activate_bin_path'
/usr/lib/ruby/2.6.0/rubygems.rb:275:in `find_spec_for_exe': Could not find 'bundler' (2.1.3) required by your /usr/share/webapps/gitlab/Gemfile.lock. (Gem::GemNotFoundException)
To update to the latest version installed on your system, run `bundle update --bundler`.
To install the missing version, run `gem install bundler:2.1.3`

Output from "gem list" (note that bundler are missing from the list which seems kind of strange?):

[root@beta ~]# gem list

*** LOCAL GEMS ***

bigdecimal (default: 1.4.1)
cmath (default: 1.0.0)
csv (default: 3.0.9)
date (default: 2.0.0)
dbm (default: 1.0.0)
e2mmap (default: 0.1.0)
etc (default: 1.0.1)
fcntl (default: 1.0.0)
fiddle (default: 1.0.0)
fileutils (default: 1.1.0)
forwardable (default: 1.2.0)
gdbm (default: 2.0.0)
io-console (default: 0.4.7)
ipaddr (default: 1.2.2)
json (default: 2.1.0)
logger (default: 1.3.0)
matrix (default: 0.1.0)
mutex_m (default: 0.1.0)
openssl (default: 2.1.2)
ostruct (default: 0.1.0)
prime (default: 0.1.0)
psych (default: 3.1.0)
rexml (default: 3.1.9)
rss (default: 0.2.7)
scanf (default: 1.0.0)
sdbm (default: 1.0.0)
shell (default: 0.7)
stringio (default: 0.0.2)
strscan (default: 1.0.0)
sync (default: 0.5.0)
thwait (default: 0.1.0)
tracer (default: 0.1.0)
webrick (default: 1.4.2)
zlib (default: 1.0.0)

Output from "gem-2.5 list" (where bundler can be found but are not used by Gitlab since it is using 2.6 now):
[root@beta ~]# gem-2.5 list

*** LOCAL GEMS ***

bigdecimal (default: 1.3.4)
bundler (2.1.3, 2.0.1)
cmath (default: 1.0.0)
csv (default: 1.0.0)
date (default: 1.0.0)
dbm (default: 1.0.0)
did_you_mean (1.2.0)
etc (default: 1.0.0)
fcntl (default: 1.0.0)
fiddle (default: 1.0.0)
fileutils (default: 1.0.2)
gdbm (default: 2.0.0)
io-console (default: 0.4.6)
ipaddr (default: 1.2.0)
json (default: 2.1.0)
minitest (5.10.3)
net-telnet (0.1.1)
openssl (default: 2.1.2)
power_assert (1.1.1)
psych (default: 3.0.2)
rake (12.3.2, 12.3.0)
rdoc (default: 6.0.1.1)
scanf (default: 1.0.0)
sdbm (default: 1.0.0)
stringio (default: 0.0.1)
strscan (default: 1.0.0)
test-unit (3.2.7)
webrick (default: 1.4.2)
xmlrpc (0.3.0)
zlib (default: 1.0.0)
Comment by Anatol Pomozov (anatolik) - Friday, 03 January 2020, 23:49 GMT
It is because recent changes to 'gitlab' package use 'bundle lock' and (as it turned out) it adds the current bundle version back to Gemfile.lock. This hardcoded bundler version is a dumb idea if you ask me.

We need to remove the BUNDLER reference from Gemfile.lock. I am preparing a fix for [community-testing].
Comment by Jacob Bang (julemand101) - Saturday, 04 January 2020, 16:04 GMT
Updated to gitlab-12.6.2-2 which now gives:
[root@beta ~]# su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled bundle exec rake db:migrate RAILS_ENV=production"
Traceback (most recent call last):
2: from /usr/bin/bundle:23:in `<main>'
1: from /usr/lib/ruby/2.6.0/rubygems.rb:294:in `activate_bin_path'
/usr/lib/ruby/2.6.0/rubygems.rb:275:in `find_spec_for_exe': can't find gem bundler (>= 0.a) with executable bundle (Gem::GemNotFoundException)

As mentioned in my previous comment, it looks like there are some problem with the "ruby-bundler 2.1.3-1" package itself since "bundler" is not showing up when running "gem list".

To verify that I have tried on my laptop to first install "ruby-bundler-2.1.2-1" which shows:
[julemand101@argon Downloads]$ gem list | grep bundler
bundler (2.1.2)

But after manually installing "ruby-bundler 2.1.3-1" the commands does not return anything:
[julemand101@argon Downloads]$ gem list | grep bundler
Comment by Anatol Pomozov (anatolik) - Saturday, 04 January 2020, 16:34 GMT
Hello Jacob sorry for the inconvenience. Note that [community-testing] contains ruby2.7 rebuild. And both ruby-bundler 2.1.3-1 gitlab-12.6.2-2 require ruby-27 (and probably more) packages from [testing] repo.

I would suggest to wait until ruby27 rebuild lands [stable] repo.
OR
go back to the older version of the [stable] package (pacman -Suuy). Then edit file /usr/share/webapps/gitlab/Gemfile.lock and remove the
'
BUNDLED WITH
2.1.2
'

section that causes your original problem.
Comment by Jacob Bang (julemand101) - Saturday, 04 January 2020, 16:36 GMT
Ah ok, that explains a lot. Well, I will wait then :)
Comment by Anatol Pomozov (anatolik) - Wednesday, 08 January 2020, 03:05 GMT
ruby2.7 landed stable. Let me know if you still see this issue.
Comment by Jacob Bang (julemand101) - Wednesday, 08 January 2020, 08:18 GMT
Updated with:

gitlab-gitaly-1.78.0-2 gitlab-shell-2:10.3.0-2 ruby-2.7.0-1 ruby-bundler-2.1.4-1 ruby-rake-13.0.1-2 rubygems-3.1.2-4 vim-runtime-8.2.0100-1 gitlab-12.6.2-2

Now I get the following output when trying to migrate. I guess it is just warnings and there was no need for migration (I checked with db:migrate:status and it shows all migrations are up):

[root@beta ~]# su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; EXECJS_RUNTIME=Disabled bundle exec rake db:migrate RAILS_ENV=production"
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/faraday-0.12.2/lib/faraday/options.rb:166: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/faraday-0.12.2/lib/faraday/options.rb:166: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/faraday-0.12.2/lib/faraday/options.rb:166: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/faraday-0.12.2/lib/faraday/options.rb:166: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/faraday-0.12.2/lib/faraday/options.rb:166: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/tzinfo-1.2.5/lib/tzinfo/ruby_core_support.rb:142: warning: Using the last argument as keyword parameters is deprecated
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/tzinfo-1.2.5/lib/tzinfo/ruby_core_support.rb:142: warning: Using the last argument as keyword parameters is deprecated
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/graphql-1.9.11/lib/graphql/schema/mutation.rb:71: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/graphql-1.9.11/lib/graphql/schema/member/has_fields.rb:10: warning: The called method `field' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/mime-types-3.2.2/lib/mime/types/logger.rb:30: warning: `_1' is reserved for numbered parameter; consider another name
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/mime-types-3.2.2/lib/mime/types/logger.rb:30: warning: `_2' is reserved for numbered parameter; consider another name
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/mime-types-3.2.2/lib/mime/types/logger.rb:30: warning: `_3' is reserved for numbered parameter; consider another name
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/json-1.8.6/lib/json/common.rb:155: warning: Using the last argument as keyword parameters is deprecated
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/faraday-0.12.2/lib/faraday/rack_builder.rb:55: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/notifications/fanout.rb:21: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/cache.rb:60: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/cache/redis_cache_store.rb:174: warning: The called method `initialize' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/type.rb:27: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/type/adapter_specific_registry.rb:9: warning: The called method `add_modifier' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/acts-as-taggable-on-6.5.0/lib/acts_as_taggable_on/tagging.rb:9: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/associations.rb:1653: warning: The called method `belongs_to' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activemodel-5.2.3/lib/active_model/type/integer.rb:13: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activemodel-5.2.3/lib/active_model/type/value.rb:8: warning: The called method `initialize' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/connection_adapters/postgresql/oid/specialized_string.rb:12: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activemodel-5.2.3/lib/active_model/type/value.rb:8: warning: The called method `initialize' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/marginalia-1.8.0/lib/marginalia.rb:94: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/connection_adapters/postgresql_adapter.rb:594: warning: The called method `execute_and_clear_without_marginalia' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/cache.rb:445: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/cache.rb:716: warning: The called method `initialize' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/json-1.8.6/lib/json/common.rb:155: warning: Using the last argument as keyword parameters is deprecated
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/json-1.8.6/lib/json/common.rb:155: warning: Using the last argument as keyword parameters is deprecated
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/doorkeeper-4.3.2/lib/doorkeeper/orm/active_record/access_grant.rb:17: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/associations.rb:1653: warning: The called method `belongs_to' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/doorkeeper-4.3.2/lib/doorkeeper/orm/active_record/access_token.rb:17: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/associations.rb:1653: warning: The called method `belongs_to' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/doorkeeper-4.3.2/lib/doorkeeper/models/concerns/ownership.rb:12: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/associations.rb:1653: warning: The called method `belongs_to' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/option_merger.rb:24: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/doorkeeper-openid_connect-1.5.0/lib/doorkeeper/openid_connect/claims_builder.rb:25: warning: The called method `claim' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/graphql-1.9.11/lib/graphql/define/defined_object_proxy.rb:38: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/graphql-1.9.11/lib/graphql/define/assign_argument.rb:6: warning: The called method `call' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/graphql-1.9.11/lib/graphql/argument.rb:139: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/graphql-1.9.11/lib/graphql/define/instance_definable.rb:226: warning: The called method `define' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/graphql-1.9.11/lib/graphql/define/defined_object_proxy.rb:38: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/graphql-1.9.11/lib/graphql/schema.rb:103: warning: The called method `call' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/notifications/fanout.rb:21: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/notifications/fanout.rb:21: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/notifications/fanout.rb:21: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activesupport-5.2.3/lib/active_support/notifications/fanout.rb:21: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/json-1.8.6/lib/json/common.rb:155: warning: Using the last argument as keyword parameters is deprecated
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/dsl/request_response.rb:23: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/error_formatter.rb:20: warning: The called method `formatter_for' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/error_formatter.rb:21: warning: Passing the keyword argument as the last hash parameter is deprecated
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/error_formatter.rb:16: warning: The called method `formatters' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/dsl/parameters.rb:134: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/validations/params_scope.rb:117: warning: The called method `push_declared_params' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/dsl/routing.rb:166: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/namespace.rb:13: warning: The called method `initialize' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/dsl/parameters.rb:160: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/validations/params_scope.rb:117: warning: The called method `push_declared_params' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/validations/params_scope.rb:119: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/grape-1.1.0/lib/grape/validations/params_scope.rb:117: warning: The called method `push_declared_params' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/scoping/default.rb:90: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/associations/builder/collection_association.rb:26: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/associations/builder/collection_association.rb:26: warning: Capturing the given block using Proc.new is deprecated; use `&block` instead
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activemodel-5.2.3/lib/active_model/naming.rb:190: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/i18n-1.7.0/lib/i18n.rb:179: warning: The called method `translate' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/transactions.rb:212: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/connection_adapters/abstract/database_statements.rb:260: warning: The called method `transaction' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/connection_adapters/abstract/transaction.rb:171: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/connection_adapters/abstract/transaction.rb:97: warning: The called method `initialize' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/persistence.rb:705: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/activerecord-5.2.3/lib/active_record/timestamp.rb:105: warning: The called method `_update_record' is defined here
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/json-1.8.6/lib/json/common.rb:155: warning: Using the last argument as keyword parameters is deprecated
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.7.0/gems/json-1.8.6/lib/json/common.rb:155: warning: Using the last argument as keyword parameters is deprecated
Comment by Anatol Pomozov (anatolik) - Wednesday, 08 January 2020, 17:11 GMT
Jacob, these are harmless ruby2.7 deprecation warnings. The best thing you can do is to vote/speakup in this upstream issue https://gitlab.com/groups/gitlab-org/-/epics/2380 updating gem dependencies to the latest versions should fix majority of the warnings,

Loading...