Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64860 - [linux-5.4.3] i915 GPU hang (rcs0 reset request timed out)

Attached to Project: Arch Linux
Opened by daimonion (demon) - Monday, 16 December 2019, 13:00 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 05 January 2020, 21:02 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Screen freezes. Excerpt from logs:

```
dec 16 13:42:15 daimonion-lap kernel: i915 0000:00:02.0: GPU HANG: ecode 9:1:0x00000000, hang on rcs0
dec 16 13:42:15 daimonion-lap kernel: GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
dec 16 13:42:15 daimonion-lap kernel: Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
dec 16 13:42:15 daimonion-lap kernel: drm/i915 developers can then reassign to the right component if it's not a kernel issue.
dec 16 13:42:15 daimonion-lap kernel: The GPU crash dump is required to analyze GPU hangs, so please always attach it.
dec 16 13:42:15 daimonion-lap kernel: GPU crash dump saved to /sys/class/drm/card0/error
dec 16 13:42:15 daimonion-lap kernel: i915 0000:00:02.0: Resetting rcs0 for hang on rcs0
dec 16 13:42:15 daimonion-lap kernel: [drm:gen8_reset_engines [i915]] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
dec 16 13:42:15 daimonion-lap kernel: i915 0000:00:02.0: Resetting chip for hang on rcs0
dec 16 13:42:15 daimonion-lap kernel: [drm:gen8_reset_engines [i915]] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
dec 16 13:42:15 daimonion-lap kernel: [drm:gen8_reset_engines [i915]] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
dec 16 13:42:15 daimonion-lap kernel: i915 0000:00:02.0: GuC is uninitialized
dec 16 13:42:23 daimonion-lap kernel: i915 0000:00:02.0: Resetting rcs0 for hang on rcs0
dec 16 13:42:31 daimonion-lap kernel: i915 0000:00:02.0: Resetting rcs0 for hang on rcs0

(continues until I emergency sync and reboot)
```

Additional info:

* package versions:
+ linux 5.4.3.arch1-1
+ mesa 19.3.0-1
+ xf86-video-intel 1:2.99.917+899+gf66d3954-1
* config and/or log files etc: provided
* link to upstream bug report, if any: none that I know of
* hardware: Intel CPU i7 6500U ("skylake")

Steps to reproduce:

Happens occasionally, I don't have steps yet, I'm sorry.
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 05 January 2020, 21:02 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#64725 
Comment by loqs (loqs) - Monday, 16 December 2019, 13:18 GMT Comment by Tom (inbx) - Wednesday, 18 December 2019, 09:10 GMT
Had the same problem, seems the problem is fixed upstream. But not for 5.4.X only 5.5.

Due to basically all Intel grafix being hit it may be helpful to backport the offered patch:

https://gitlab.freedesktop.org/drm/intel/issues/161#note_363380
Comment by loqs (loqs) - Wednesday, 18 December 2019, 13:49 GMT Comment by dummys (dummys) - Wednesday, 18 December 2019, 18:50 GMT
same problem here:
[ 2815.728728] i915 0000:00:02.0: Resetting rcs0 for hang on rcs0
[ 2815.729519] [drm:gen8_reset_engines [i915]] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
[ 2815.729699] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 2815.731498] [drm:gen8_reset_engines [i915]] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
[ 2815.732278] [drm:gen8_reset_engines [i915]] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
[ 2867.782038] i915 0000:00:02.0: Resetting rcs0 for hang on rcs0
[ 2875.675373] i915 0000:00:02.0: Resetting rcs0 for hang on rcs0
Comment by dummys (dummys) - Wednesday, 18 December 2019, 23:11 GMT
same problem here:
[ 2815.728728] i915 0000:00:02.0: Resetting rcs0 for hang on rcs0
[ 2815.729519] [drm:gen8_reset_engines [i915]] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
[ 2815.729699] i915 0000:00:02.0: Resetting chip for hang on rcs0
[ 2815.731498] [drm:gen8_reset_engines [i915]] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
[ 2815.732278] [drm:gen8_reset_engines [i915]] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
[ 2867.782038] i915 0000:00:02.0: Resetting rcs0 for hang on rcs0
[ 2875.675373] i915 0000:00:02.0: Resetting rcs0 for hang on rcs0

Loading...