Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64847 - [linux] nvidia HDMI extremely distorted after upgrade

Attached to Project: Arch Linux
Opened by Peter Ã…berg (kvt2000) - Sunday, 15 December 2019, 11:42 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 18 December 2019, 01:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Jan Alexander Steffens (heftig)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 13
Private No

Details

Description:


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
Nvidia HDMI audio extremely distorted (unusable) with latest linux-5.4.3.arch1-1 and nvidia-440.44-2.
Downgrading to linux-5.4.2.arch1-1 + nvidia-440.36-5 solved the issue.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 18 December 2019, 01:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 5.4.4.arch1-1
Comment by Trygve Aaberge (trygveaa) - Sunday, 15 December 2019, 12:26 GMT
I have the same issue. I notice that in addition to the sound being extremely distorted and scratchy, the volume slider in pavucontrol doesn't work. The problem appears both with pulseaudio and alsa.

Downgrading also solves the issue for me. linux-5.4.2.arch1-1 with nvidia-440.44-1 works too.
Comment by loqs (loqs) - Sunday, 15 December 2019, 12:29 GMT Comment by Ringo Starr (kanto) - Sunday, 15 December 2019, 17:26 GMT
I can confirm that this also happened to me, thought it was a pulseaudio issue, but downgrading pulseaudio did not help. So, the problem must be related with the nvidia driver.

Edit: I am using gnome btw, GTX 1060 nvidia 440.44-2
Comment by Batou (Batou) - Sunday, 15 December 2019, 18:37 GMT
Confirmed with GTX 1080 and Linux 5.4.3 with nvidia-dkms 440.44-2 driver.
Comment by Tom Kuschel (tomdollar) - Sunday, 15 December 2019, 23:00 GMT
confirmed with GTX 660 and linux-5.4.3 + nvidia 440.44-2 - extremely distorted signal.
The fix in kernel https://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound.git/commit/?id=6fd739c04ffd877641b01371f9fde67901e7f9cb
worked for me.
Comment by Samuel Jones (OrangutanClyde) - Monday, 16 December 2019, 08:27 GMT
I can confirm audio issues also, with the following: Kernel 5.4.3-arch1-1; nvidia 440.44-2; GTX 1060 audio via HDMI.

Booting with linux-lts (4.19.89-1-lts) with nvidia-dkms 440.44-2 resolves the audio issues for now. I'll keep an eye out for new arch kernel release.

Thanks
Samuel.
Comment by arsen (arsen) - Monday, 16 December 2019, 11:18 GMT
confirmed with GTX 680 + linux-5.4.3
Comment by Arek (Domker_) - Monday, 16 December 2019, 20:43 GMT
Confirmed with GTX 980 + linux-5.4.3
(on 5.4.2 works good)
Comment by Vitaly Iskra (vitaly_iskra) - Monday, 16 December 2019, 21:15 GMT
Mine results (RTX 2080 TI):

* linux-5.4.3.arch1-1 nvidia-440.44-2: sound distorted.
* linux-5.4.3.arch1-1 nvidia-440.44-1: nvidia-modprobe cannot load module, gnome tries to start with wayland and fails.
* linux-5.4.2.arch1-1 nvidia-440.44-1: Everything works fine.
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 17 December 2019, 10:37 GMT
Well, that's weird. Does anyone know whether this is tracked either in the nvidia forums or on kernel bugzilla somewhere?
Comment by loqs (loqs) - Tuesday, 17 December 2019, 10:39 GMT Comment by Frederick Zhang (FrederickZh) - Tuesday, 17 December 2019, 10:52 GMT
https://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound.git/commit/?id=6fd739c04ffd877641b01371f9fde67901e7f9cb worked for me as well (GTX980M). Is this something that can be backported to this package?
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 17 December 2019, 11:06 GMT
So then this is actually a kernel issue?
Comment by Frederick Zhang (FrederickZh) - Tuesday, 17 December 2019, 11:15 GMT
I think so. Applying the mentioned patch was the only thing I needed to do to fix it.
Comment by Ringo Starr (kanto) - Tuesday, 17 December 2019, 11:30 GMT
How do you apply the patch?
Comment by Frederick Zhang (FrederickZh) - Tuesday, 17 December 2019, 11:59 GMT
IIRC it was:

```
diff --git a/repos/core-x86_64/PKGBUILD b/repos/core-x86_64/PKGBUILD
index 124f2dc..5582099 100644
--- a/repos/core-x86_64/PKGBUILD
+++ b/repos/core-x86_64/PKGBUILD
@@ -16,16 +16,18 @@ makedepends=(
options=('!strip')
_srcname=archlinux-linux
source=(
"$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=$_srctag"
+ "6fd739c04ffd877641b01371f9fde67901e7f9cb.patch::https://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound.git/patch/?id=6fd739c04ffd877641b01371f9fde67901e7f9cb"
config # the main kernel config file
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
+ 'a8c93ef21ec2e065cf03bff74a235e02bc958114d28e4cc36abab5295b0dafbb'
'5d58a2115892839997ae7dcca226697c34b656de7685cb3eb8696451dc5100a0')

export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
```
Comment by loqs (loqs) - Wednesday, 18 December 2019, 00:38 GMT
Can you confirm the issue is fixed in linux 5.4.4.arch1-1?
Comment by Andrew Rabert (Draje) - Wednesday, 18 December 2019, 01:56 GMT
Working fine for me in 5.4.4 (980 Ti).

Loading...