Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64806 - [virtualbox-guest-dkms] failed to build with linux-lts

Attached to Project: Community Packages
Opened by Philip Müller (philm) - Wednesday, 11 December 2019, 08:27 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 26 February 2020, 14:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

With package update to 6.0.14-4 it is not possible to build guest modules for linux-lts.

Additional info:

Kernels lower than 5.1 can't compile vboxsf in v12 or higher.

Steps to reproduce:

Try to compile vboxsf later than 30d88e3b8780989c610f6b8b8723307e247b07ca with any kernel below 5.1

Solution:

Provide a vboxsf based on 30d88e3b8780989c610f6b8b8723307e247b07ca for kernels lower than 5.1 and you may provide the latest master for kernels equal or higher than 5.1.

This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 26 February 2020, 14:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux-lts is 5.4 now
Comment by Jack Trice (anonymous352) - Friday, 13 December 2019, 12:56 GMT
Prevents the use of Shared Folders between VirtualBox Host and VirtualBox Guest systems (for Kernels lower than 5.1)
Comment by Valera (khvalera) - Friday, 20 December 2019, 21:37 GMT
I confirm! I have the same problem

Loading...