Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#64785 - [pacman] cannot upgrade system with solvable conflicts

Attached to Project: Pacman
Opened by Norbert Pfeiler (npfeiler) - Monday, 09 December 2019, 17:17 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 09 December 2019, 18:16 GMT
Task Type Bug Report
Category Packages: Core
Status Unconfirmed   Reopened
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
I have a system that wasn’t upgraded recently
a sysupgrade contains upgrades for python-gast as well as python-tensorflow
the new version of python-tensorflow looses the dependency for python-gast in favor of python-gast02, but pacman doesn’t offer to remove python-gast (which was implicitly installed and conflicts python-gast02)

To resolve the situation i can do `pacman -Sy python-tensorflow` followed by `pacman -Syu` but i think pacman should handle this better.

Additional info:
* package version(s)
Pacman v5.1.3 - libalpm v11.0.3

community/python-gast 0.3.2-1 0.3.2-3
community/python-gast02 0.2.2-1
community/python-tensorflow 2.0.0-2 2.1.0rc0-1

* config and/or log files etc.
debug: searching for replacements for python-gast in core
debug: searching for replacements for python-gast in extra
debug: searching for replacements for python-gast in community
debug: new version of 'python-gast' found (0.3.2-1 => 0.3.2-3)
debug: adding package python-gast-0.3.2-3 to the transaction targets
debug: checkdeps: package python-gast-0.3.2-3
debug: checkdeps: missing dependency 'python' for package 'python-gast'
debug: checkdeps: missing dependency 'python-gast02' for package 'python-tensorflow'
debug: checkdeps: package python-gast02-0.2.2-1
debug: checkdeps: missing dependency 'python' for package 'python-gast02'
debug: pulling dependency python-gast02 (needed by python-tensorflow)
debug: package python-gast02 conflicts with python-gast (by python-gast)
debug: conflicting packages in the sync list: 'python-gast02' <-> 'python-gast'
:: python-gast02 and python-gast are in conflict

Steps to reproduce:
pacman -Syu



This task depends upon

Comment by Eli Schwartz (eschwartz) - Monday, 09 December 2019, 18:10 GMT
  • Field changed: Attached to Project (Arch Linux → Pacman)
Bug is about Pacman software, not archlinux packaging.
Comment by Eli Schwartz (eschwartz) - Monday, 09 December 2019, 18:12 GMT
looking for conflicting packages...
:: python-gast02 and python-gast are in conflict. Remove python-gast? [y/N] y

Solution: don't use --noconfirm or select enter, the conflict is solvable but defaults to the resolution "prefer existing packages, and do nothing".

EDIT: hmm, not sure what happens if -u adds a package upgrade at the same time. Maybe this is an issueful edge case.

EDIT2: okay, yeah, that's annoying.

Loading...