Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64751 - mercurial-5.2-1 breaks with message "abort: No module named peer!"

Attached to Project: Arch Linux
Opened by Robin Becker (replabrobin) - Friday, 06 December 2019, 07:44 GMT
Last edited by Antonio Rojas (arojas) - Friday, 06 December 2019, 09:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
after upgrade to mercurial-5.2-1 many commands eg hg id are breaking with message

abort: No module named peer!

even if all optional extensions are turned off in .hgrc.

Downgrade to 5.1.2-1 restores expected behaviour.


Steps to reproduce:
upgrade to mercurial-5.2-1 and use command hg id in an existing repository
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 06 December 2019, 09:17 GMT
Reason for closing:  Not a bug
Additional comments about closing:  hg-git is not supported
Comment by Antonio Rojas (arojas) - Friday, 06 December 2019, 08:26 GMT
Please post the full output of the command 'hg id --traceback'
Comment by Robin Becker (replabrobin) - Friday, 06 December 2019, 09:15 GMT
in a strace diff between 5.2 & 5.1 this appears to be the reason for failure

stat("/usr/lib/python2.7/site-packages/mercurial/repository", 0x7ffd11bad3c0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib/python2.7/site-packages/mercurial/repository.so", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib/python2.7/site-packages/mercurial/repositorymodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib/python2.7/site-packages/mercurial/repository.py", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib/python2.7/site-packages/mercurial/repository.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib/python2.7/site-packages/mercurial/peer", 0x7ffd11bad3c0) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib/python2.7/site-packages/mercurial/peer.so", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib/python2.7/site-packages/mercurial/peermodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib/python2.7/site-packages/mercurial/peer.py", O_RDONLY) = -1 ENOENT (No such file or directory)
openat(AT_FDCWD, "/usr/lib/python2.7/site-packages/mercurial/peer.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
close(3) = 0
write(2, "abort: No module named peer!\n", 29abort: No module named peer!
) = 29
Comment by Robin Becker (replabrobin) - Friday, 06 December 2019, 09:16 GMT
traceback

robin@minikat:~/tmp/sdata
$ hg id --traceback
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/mercurial/scmutil.py", line 177, in callcatch
return func()
File "/usr/lib/python2.7/site-packages/mercurial/dispatch.py", line 414, in _runcatchfunc
return _dispatch(req)
File "/usr/lib/python2.7/site-packages/mercurial/dispatch.py", line 1128, in _dispatch
intents=func.intents,
File "/usr/lib/python2.7/site-packages/mercurial/hg.py", line 220, in repository
createopts=createopts,
File "/usr/lib/python2.7/site-packages/mercurial/hg.py", line 194, in _peerorrepo
hook(ui, obj)
File "/usr/lib/python2.7/site-packages/hggit/__init__.py", line 221, in reposetup
if not isinstance(repo, gitrepo.gitrepo):
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 157, in __getattr__
self._load()
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 97, in _load
_origimport, head, globals, locals, None, level
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 44, in _hgextimport
return importfunc(name, globals, *args, **kwargs)
File "/usr/lib/python2.7/site-packages/hggit/gitrepo.py", line 10, in <module>
from mercurial.peer import peerrepository
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 284, in _demandimport
mod = _hgextimport(_origimport, name, globals, locals)
File "/usr/lib/python2.7/site-packages/hgdemandimport/demandimportpy2.py", line 44, in _hgextimport
return importfunc(name, globals, *args, **kwargs)
ImportError: No module named peer
abort: No module named peer!

Loading...