Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64741 - Error while building lib32-libpulse

Attached to Project: Arch Linux
Opened by Domenico Iezzi (nomore66201) - Thursday, 05 December 2019, 11:04 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 05 December 2019, 11:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When building lib32-libpulse package I encounter the following error during linking phase:

/usr/bin/ld: /usr/lib/libsoxr.so: error adding symbols: file in wrong format
collect2: error: ld returned 1 exit status
[328/426] Linking target src/utils/pactl.
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
Aborting...

I'm compiling lib32-libpulse without any modification.

Additional info:
* package version: 13.0-1
* config and/or log files: attached file

Steps to reproduce:
Build lib32-libpulse package
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 05 December 2019, 11:50 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Builds fine in a clean chroot

Loading...