Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64735 - [qemu] edk2 file packaging

Attached to Project: Arch Linux
Opened by loqs (loqs) - Wednesday, 04 December 2019, 17:02 GMT
Last edited by Anatol Pomozov (anatolik) - Wednesday, 08 January 2020, 21:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Anatol Pomozov (anatolik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The json config files for the shipped edk2 firmware are packaged in usr/share/qemu/firmware/ in the qemu / qemu-headless package.
The edk2 firmware is packaged in usr/share/qemu/ qemu-arch-extra an optional dependency of qemu / qemu-headless.
Since libvirt 5.8 the presence of json files in /usr/share/qemu/ or /etc/qemu/firmware causes firmware specified in /etc/libvirt/qemu.conf to be ignored.
This causes libvirt to disable EFI mode due to missing firmware.

Placing the edk2 firmware into same package as its json configs or removing all of the edk2 files would prevent such firmware detection failure.
If the edk2 files were removed or split from qemu / qemu-headless it would also allow firmware to specified in /etc/libvirt/qemu.conf
as a workaround until json files are added to ovmf.

Additional info:
* qemu 4.1.1-1
*  FS#64175 
*  FS#64206 

Steps to reproduce:
Install libvirt then start libvirt observe edk2 firmware is not located.
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Wednesday, 08 January 2020, 21:05 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#64206 

Loading...