Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#64721 - Upgrading linux from 5.3.13 to 5.4.1 fails with "module not found: `aes_x86_64'"

Attached to Project: Arch Linux
Opened by blueman (blueman) - Tuesday, 03 December 2019, 20:18 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 03 December 2019, 22:09 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Upgrading linux from 5.3.13 to 5.4.1 prints this error:

[2019-12-03T14:39:15+0100] [PACMAN] Running 'pacman -S -y -u --config /etc/pacman.conf --'
[2019-12-03T14:39:15+0100] [PACMAN] synchronizing package lists
[2019-12-03T14:39:18+0100] [PACMAN] starting full system upgrade
[2019-12-03T14:39:25+0100] [ALPM] running '60-mkinitcpio-remove.hook'...
[2019-12-03T14:39:25+0100] [ALPM] transaction started
[2019-12-03T14:39:25+0100] [ALPM] upgraded cpupower (5.4-1 -> 5.4-2)
[2019-12-03T14:39:29+0100] [ALPM] upgraded linux (5.3.13.1-1 -> 5.4.1.arch1-1)
[2019-12-03T14:39:29+0100] [ALPM] upgraded nvidia (440.36-2 -> 440.36-4)
[2019-12-03T14:39:29+0100] [ALPM] transaction completed
[2019-12-03T14:39:29+0100] [ALPM] running '30-systemd-daemon-reload.hook'...
[2019-12-03T14:39:29+0100] [ALPM] running '30-systemd-update.hook'...
[2019-12-03T14:39:29+0100] [ALPM] running '60-depmod.hook'...
[2019-12-03T14:39:34+0100] [ALPM] running '90-mkinitcpio-install.hook'...
[2019-12-03T14:39:34+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2019-12-03T14:39:34+0100] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2019-12-03T14:39:34+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.4.1-arch1-1
[2019-12-03T14:39:34+0100] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2019-12-03T14:39:34+0100] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2019-12-03T14:39:34+0100] [ALPM-SCRIPTLET] -> Running build hook: [autodetect]
[2019-12-03T14:39:34+0100] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2019-12-03T14:39:34+0100] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2019-12-03T14:39:35+0100] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2019-12-03T14:39:35+0100] [ALPM-SCRIPTLET] -> Running build hook: [keymap]
[2019-12-03T14:39:35+0100] [ALPM-SCRIPTLET] -> Running build hook: [encrypt]
[2019-12-03T14:39:35+0100] [ALPM-SCRIPTLET] -> Running build hook: [resume]
[2019-12-03T14:39:35+0100] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2019-12-03T14:39:35+0100] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2019-12-03T14:39:35+0100] [ALPM-SCRIPTLET] ==> ERROR: module not found: `aes_x86_64'
[2019-12-03T14:39:35+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-12-03T14:39:35+0100] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2019-12-03T14:39:37+0100] [ALPM-SCRIPTLET] ==> WARNING: errors were encountered during the build. The image may not be complete.
[2019-12-03T14:39:37+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2019-12-03T14:39:37+0100] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2019-12-03T14:39:37+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.4.1-arch1-1
[2019-12-03T14:39:37+0100] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2019-12-03T14:39:37+0100] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2019-12-03T14:39:37+0100] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2019-12-03T14:39:37+0100] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2019-12-03T14:39:37+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2019-12-03T14:39:38+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2019-12-03T14:39:39+0100] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2019-12-03T14:39:39+0100] [ALPM-SCRIPTLET] -> Running build hook: [keymap]
[2019-12-03T14:39:39+0100] [ALPM-SCRIPTLET] -> Running build hook: [encrypt]
[2019-12-03T14:39:40+0100] [ALPM-SCRIPTLET] -> Running build hook: [resume]
[2019-12-03T14:39:40+0100] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2019-12-03T14:39:40+0100] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2019-12-03T14:39:40+0100] [ALPM-SCRIPTLET] ==> ERROR: module not found: `aes_x86_64'
[2019-12-03T14:39:41+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-12-03T14:39:41+0100] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2019-12-03T14:39:45+0100] [ALPM-SCRIPTLET] ==> WARNING: errors were encountered during the build. The image may not be complete.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 03 December 2019, 22:09 GMT
Reason for closing:  Not a bug
Comment by loqs (loqs) - Tuesday, 03 December 2019, 20:34 GMT
The module was removed with 5.4 [1] as it was slower than the generic implementation.
Edit:
If you remove aes_x86_64 from the modules entry of mkinitcpio.conf is there an issue with 5.4?
Comment by blueman (blueman) - Tuesday, 03 December 2019, 21:34 GMT
Removing the module "aes_x86_64" from /etc/mkinitcpio.conf worked. My LUKS-encrypted system does still boot fine.

Loading...